summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Misbakh-Soloviov <mva@gentoo.org>2020-09-14 12:16:11 +0700
committerVadim Misbakh-Soloviov <mva@gentoo.org>2020-09-14 12:16:11 +0700
commit5cfe2cac99022c6d6d8b202dbdd66ec75ecb9916 (patch)
tree00d35fc1a92f01dc45b2dfbfe942f0db027d1c0b /app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20200914.ebuild
parentapp-emulation/lxd: remove old 4.0.2 (diff)
downloadgentoo-5cfe2cac99022c6d6d8b202dbdd66ec75ecb9916.tar.gz
gentoo-5cfe2cac99022c6d6d8b202dbdd66ec75ecb9916.tar.bz2
gentoo-5cfe2cac99022c6d6d8b202dbdd66ec75ecb9916.zip
app-shells/gentoo-zsh-completions: bump to the new version
Closes: https://bugs.gentoo.org/439978 Package-Manager: Portage-3.0.6, Repoman-2.3.20 Signed-off-by: Vadim Misbakh-Soloviov <mva@gentoo.org>
Diffstat (limited to 'app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20200914.ebuild')
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20200914.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20200914.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20200914.ebuild
new file mode 100644
index 000000000000..ff98a19ddf2a
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20200914.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/gentoo/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}