summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-03-10 16:43:30 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-03-10 16:45:17 +0100
commit748250033d52ef9a8ea16d1b7914a2b3086c4a5f (patch)
treed98f1e78d3d3eae2368a2cd07a20a0d8059aa13f /app-shells/hstr
parentdev-python/httpretty: Bump to 0.9.7 (diff)
downloadgentoo-748250033d52ef9a8ea16d1b7914a2b3086c4a5f.tar.gz
gentoo-748250033d52ef9a8ea16d1b7914a2b3086c4a5f.tar.bz2
gentoo-748250033d52ef9a8ea16d1b7914a2b3086c4a5f.zip
app-shells/hstr: version bump.
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells/hstr')
-rw-r--r--app-shells/hstr/Manifest1
-rw-r--r--app-shells/hstr/files/hstr-2.1-fix-ncurses-configure.patch81
-rw-r--r--app-shells/hstr/hstr-2.1.ebuild33
3 files changed, 115 insertions, 0 deletions
diff --git a/app-shells/hstr/Manifest b/app-shells/hstr/Manifest
index b14972debef6..602b85af6a41 100644
--- a/app-shells/hstr/Manifest
+++ b/app-shells/hstr/Manifest
@@ -1 +1,2 @@
DIST hstr-2.0.tar.gz 1242802 BLAKE2B 24f1a870e6aa12b6544a38601c6bc654e01aa1a185c4f7735559aa3220ed8d9fb840e298526b9e4a177000f2ec5c08caee5da97e13783e4114bde5276ee1e85e SHA512 50d5e8e61aa853dab0093f4225d3329e98bc59609d8d59abf832cd4cb616d78a2fa091d1ad8d16f3543276c4ead95a419f33a13a96f423bf93dc648da32740b7
+DIST hstr-2.1.tar.gz 1244067 BLAKE2B aa37f26a5ba8ee465a03212cc80e55b9581e59cbb535f17fda8e59bed062f0b0065d456d8566927c089595b92270b83235f0bf73f26ac88704bd933c1926cd5b SHA512 ea217ac2b6dcb7e283f83d15524b47f88c5c8cfb82e5728537750a2ec8526f03304503a5bb67970d893e10057aba087aa86a67548aa361c892b6ee3e81903122
diff --git a/app-shells/hstr/files/hstr-2.1-fix-ncurses-configure.patch b/app-shells/hstr/files/hstr-2.1-fix-ncurses-configure.patch
new file mode 100644
index 000000000000..215fd5cedfc9
--- /dev/null
+++ b/app-shells/hstr/files/hstr-2.1-fix-ncurses-configure.patch
@@ -0,0 +1,81 @@
+diff --git a/configure.ac b/configure.ac
+index 1676ec8..73c8be5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,39 +47,33 @@ then
+ fi
+
+ # PKG_CHECK_MODULES macro is NOT used to avoid confusing syntax errors in case that pkg-config is NOT installed
+-AC_CHECK_LIB(ncursesw, killwchar, [],
+-[
+- AC_CHECK_LIB(ncurses, killwchar, [],
+- [
+- AC_SUBST([NCURSESW_CFLAGS])
+- AC_SUBST([NCURSESW_LIBS])
+- if pkg-config --exists ncursesw
+- then
+- AC_MSG_NOTICE([Module ncursesw found])
+- NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
+- NCURSESW_LIBS=`pkg-config --libs ncursesw`
+- else
+- if pkg-config --exists ncurses
+- then
+- AC_MSG_NOTICE([Module ncurses found])
+- NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
+- NCURSESW_LIBS=`pkg-config --libs ncurses`
+- else
+- AS_CASE([$host_os],
+- [darwin*],
+- [
+- AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
+- AC_CHECK_HEADER(curses.h)
+- ],
+- [
+- AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
+- AC_CHECK_HEADER(ncursesw/curses.h)
+- ]
+- )
+- fi
+- fi
+- ]) # FAIL of ncurses
+-]) # FAIL of ncursesw
++AC_SUBST([NCURSESW_CFLAGS])
++AC_SUBST([NCURSESW_LIBS])
++if pkg-config --exists ncursesw
++then
++ AC_MSG_NOTICE([Module ncursesw found])
++ NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
++ NCURSESW_LIBS=`pkg-config --libs ncursesw`
++else
++ if pkg-config --exists ncurses
++ then
++ AC_MSG_NOTICE([Module ncurses found])
++ NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
++ NCURSESW_LIBS=`pkg-config --libs ncurses`
++ else
++ AS_CASE([$host_os],
++ [darwin*],
++ [
++ AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
++ AC_CHECK_HEADER(curses.h)
++ ],
++ [
++ AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
++ AC_CHECK_HEADER(ncursesw/curses.h)
++ ]
++ )
++ fi
++fi
+
+
+ # Checks for libraries.
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 7640d21..17a82b7 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -37,4 +37,4 @@ hstr_SOURCES = \
+ install-exec-hook:
+ ln $(DESTDIR)$(bindir)/hstr$(EXEEXT) $(DESTDIR)$(bindir)/hh$(EXEEXT)
+
+-hstr_LDADD = $(NCURSES_LIBS)
++hstr_LDADD = $(NCURSESW_LIBS)
diff --git a/app-shells/hstr/hstr-2.1.ebuild b/app-shells/hstr/hstr-2.1.ebuild
new file mode 100644
index 000000000000..f9bffba4e61d
--- /dev/null
+++ b/app-shells/hstr/hstr-2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Shell history suggest box"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode]"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( CONFIGURATION.md README.md )
+
+PATCHES=( ${FILESDIR}/${P}-fix-ncurses-configure.patch )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+ eautoreconf
+}