summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-01 21:16:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-01 21:16:16 +0300
commitcfbbba3fd45cd18cb0331c6483266d446748fb44 (patch)
tree91273be19f58bbe6cb88733476eec7d1229e6955 /app-shells/liquidprompt
parentdev-python/ovs: enable py3.11 (diff)
downloadgentoo-cfbbba3fd45cd18cb0331c6483266d446748fb44.tar.gz
gentoo-cfbbba3fd45cd18cb0331c6483266d446748fb44.tar.bz2
gentoo-cfbbba3fd45cd18cb0331c6483266d446748fb44.zip
app-shells/liquidprompt: add 2.1.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-shells/liquidprompt')
-rw-r--r--app-shells/liquidprompt/Manifest1
-rw-r--r--app-shells/liquidprompt/liquidprompt-2.1.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/liquidprompt/Manifest b/app-shells/liquidprompt/Manifest
index 5fb5592fab43..89b3ba10d07d 100644
--- a/app-shells/liquidprompt/Manifest
+++ b/app-shells/liquidprompt/Manifest
@@ -1,2 +1,3 @@
DIST liquidprompt-2.0.3.tar.gz 539054 BLAKE2B c94375e0def1764103afe04bb47ff25ced2aeb940b45392bea8a2889ce88d1ea0e03efc0652ec8bc873b9910bee7208e48aaef9a846760177049cc550a5cd8b0 SHA512 a77f1548dd233de9877b2b5dd4a64f05ef03890917486792eb1c362708ab0b635c517cc2a3ddc82731940017f209f626d177a4ac0b5554566faa720a7d88b550
DIST liquidprompt-2.0.4.tar.gz 536123 BLAKE2B 181fe4c59d1a68e03893b1a2144d6b800d8d950a48d38b12fa04aafb01384a08d5b95741a9fac524b353cf7f1b5e09f838d45222009dfb94dcc890ec2a6ab985 SHA512 611931c5572abf1471a2cac1a88d91fadb935e97a3c32bb0ff8a5cc007ac96dd7a88575feecdf033a77226b769504fde93d4afd93fa60277eafdb5f96fb18bcb
+DIST liquidprompt-2.1.1.tar.gz 621781 BLAKE2B b23dcbf44f6b0b3a56aa59fffc38336b00be5c3066729445be6b3cb53fb4cb39e12c3f4a31e30a2bfca2abc7a5b02d4015662fb8d303d42406976b6f4b24d1b9 SHA512 88511bb74355c1ffd9ab710170905daeac673073083e81ec165bf4dad47377a47eb5eb6f387010439456c6e6df059ff640bcde8e16eeb60621d1c3ae6b502963
diff --git a/app-shells/liquidprompt/liquidprompt-2.1.1.ebuild b/app-shells/liquidprompt/liquidprompt-2.1.1.ebuild
new file mode 100644
index 000000000000..aed3cbeb58e8
--- /dev/null
+++ b/app-shells/liquidprompt/liquidprompt-2.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Full-featured & carefully designed adaptive prompt for Bash & Zsh"
+HOMEPAGE="https://github.com/nojhan/liquidprompt"
+SRC_URI="
+ https://github.com/nojhan/liquidprompt/releases/download/v${PV}/${PN}-v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-util/shunit2 )"
+
+DOCS=( CHANGELOG.md example.bashrc README.md )
+
+src_test() {
+ cp "$(type -P shunit2)" tests/shunit2 || die
+ ./tests.sh || die
+}
+
+src_install() {
+ default
+ dobin liquidprompt
+
+ insinto /usr/share/${PN}
+ doins liquid.theme
+ doins liquid.ps1
+ doins -r themes
+
+ insinto /etc/
+ newins liquidpromptrc-dist liquidpromptrc
+}