summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-11-22 16:26:28 -0700
committerChristoph Junghans <junghans@gentoo.org>2017-11-22 16:26:44 -0700
commitefd9349ac15ae636f7848ef331d57d6fefb42e56 (patch)
treeefb3bc0a589703706695542bba05b4a513863652 /app-shells/mpibash
parentnet-im/signal-desktop-bin: enable PaX marking. (diff)
downloadgentoo-efd9349ac15ae636f7848ef331d57d6fefb42e56.tar.gz
gentoo-efd9349ac15ae636f7848ef331d57d6fefb42e56.tar.bz2
gentoo-efd9349ac15ae636f7848ef331d57d6fefb42e56.zip
app-shells/mpibash: version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-shells/mpibash')
-rw-r--r--app-shells/mpibash/Manifest1
-rw-r--r--app-shells/mpibash/mpibash-1.3.ebuild43
-rw-r--r--app-shells/mpibash/mpibash-9999.ebuild15
3 files changed, 52 insertions, 7 deletions
diff --git a/app-shells/mpibash/Manifest b/app-shells/mpibash/Manifest
index 4d8ea88158d7..3bdc4e71f6a3 100644
--- a/app-shells/mpibash/Manifest
+++ b/app-shells/mpibash/Manifest
@@ -1 +1,2 @@
DIST mpibash-1.2.tar.gz 347083 SHA256 5c2faaa74464111205dbae4799bd89c2425810ec3708d004237b42d620c8be57 SHA512 db755dd2c6212a8d7dfd6cbff17d5dffcbc3b6a0286abdad4d2e21790453d2356e88c566abe4648da138d6964098fad581b8fd5beae1335f5787de92f4659104 WHIRLPOOL 94fcf50d89250a6478a2ed56a0c1769dd678869884e1e80066ebdb479dd0c6d64048ade7829020fdad050b1e77a2315ab7e325a97aa472291d3e9a4888c915e3
+DIST mpibash-1.3.tar.gz 369803 BLAKE2B b1959deaa2d5b3bce1a66e5ef0ff41ad156093aec9cc1efcd12873b6d5814ad1586ff951d6fd7f37dab6a55040378774b435edc4e2c8892952480539864f91fa SHA512 4728565239aae80013322231a928fd1e9a59484614a92cf7e314d0cd5c090d3a47de395507ce52f71a6900245855089d659c6509f8c4df3bfd88e46fc2187749
diff --git a/app-shells/mpibash/mpibash-1.3.ebuild b/app-shells/mpibash/mpibash-1.3.ebuild
new file mode 100644
index 000000000000..76bbce43cda2
--- /dev/null
+++ b/app-shells/mpibash/mpibash-1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/lanl/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
+src_configure() {
+ econf --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash \
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
+}
+
+src_install() {
+ default
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}
diff --git a/app-shells/mpibash/mpibash-9999.ebuild b/app-shells/mpibash/mpibash-9999.ebuild
index 594ac6bc88cb..76bbce43cda2 100644
--- a/app-shells/mpibash/mpibash-9999.ebuild
+++ b/app-shells/mpibash/mpibash-9999.ebuild
@@ -3,13 +3,12 @@
EAPI=5
-inherit autotools-utils multilib
+inherit autotools multilib
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
inherit git-r3
KEYWORDS=""
- AUTOTOOLS_AUTORECONF=1
else
SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
@@ -27,16 +26,18 @@ DEPEND="virtual/mpi
sys-cluster/libcircle"
RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
src_configure() {
- local myeconfargs=(
+ econf --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash \
--with-bashdir="${EPREFIX}"/usr/include/bash-plugins
- --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
- )
- autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
+ default
sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
}