summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-04-25 17:50:10 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-04-26 07:00:27 +0000
commit8b203a8a1f2fe9384c35dc60367e8be78e29f7cf (patch)
treefdec5b56dd3622e128851cde1ba5de28d6e1ad05 /app-shells/mpv-bash-completion
parentapp-doc/cppman: bump to 0.4.8 (diff)
downloadgentoo-8b203a8a1f2fe9384c35dc60367e8be78e29f7cf.tar.gz
gentoo-8b203a8a1f2fe9384c35dc60367e8be78e29f7cf.tar.bz2
gentoo-8b203a8a1f2fe9384c35dc60367e8be78e29f7cf.zip
app-shells/mpv-bash-completion: new package
Bash completion for the mpv video player. Package-Manager: portage-2.2.28 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells/mpv-bash-completion')
-rw-r--r--app-shells/mpv-bash-completion/Manifest1
-rw-r--r--app-shells/mpv-bash-completion/files/mpv-bash-completion-0.16-fix-no-flag-options-completion.patch30
-rw-r--r--app-shells/mpv-bash-completion/metadata.xml15
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-0.16.ebuild35
4 files changed, 81 insertions, 0 deletions
diff --git a/app-shells/mpv-bash-completion/Manifest b/app-shells/mpv-bash-completion/Manifest
new file mode 100644
index 000000000000..c7a14a3aaf4d
--- /dev/null
+++ b/app-shells/mpv-bash-completion/Manifest
@@ -0,0 +1 @@
+DIST mpv-bash-completion-0.16.tar.gz 15023 SHA256 ceee842ad8498afc49c9a6ded424f2f301f681513a901d5efb6fd641ba163e10 SHA512 cdfc126a170026ac1c5654a43c6b155a648b090b4b0fed83494725c2d357d5c22dca3e43b2e6a8ea461db83c49880454d0bd8f7209b01d7c9bcdd232d532abd0 WHIRLPOOL 17b29f79435033fefb1800f28c6d1d37506d116cab49bdc06470a6ff792a4009e624a2150bdca2eeaa04756238e314e7277a9b34c6241e9845e8cdd76267df82
diff --git a/app-shells/mpv-bash-completion/files/mpv-bash-completion-0.16-fix-no-flag-options-completion.patch b/app-shells/mpv-bash-completion/files/mpv-bash-completion-0.16-fix-no-flag-options-completion.patch
new file mode 100644
index 000000000000..7dd3e39eee42
--- /dev/null
+++ b/app-shells/mpv-bash-completion/files/mpv-bash-completion-0.16-fix-no-flag-options-completion.patch
@@ -0,0 +1,30 @@
+commit 3a5d3b89ecb3a05b58ad8d160a35c0795daf0c9a
+Author: Jens John <dev@2ion.de>
+Date: Sun Feb 7 20:35:17 2016 +0900
+
+Fix completion of --no-* patterned options
+---
+
+diff --git a/BUGS b/BUGS
+deleted file mode 100644
+index 337eb25..0000000
+--- a/BUGS
++++ /dev/null
+@@ -1,4 +0,0 @@
+-- Options of type 'Flag' with no default and no [nocfg] marker are
+- not being completed correctly (exmaple: --no-audio). The completion
+- wrongly suggests to complete them in the format --no-audio=*, but
+- these options do not accept a yes/no flag.
+diff --git a/gen.sh b/gen.sh
+index 87e7e35..596f349 100755
+--- a/gen.sh
++++ b/gen.sh
+@@ -149,7 +149,7 @@ for line in $(mpv --list-options \
+ "$(printf "$template_case" "$key" "$tail")")
+ ;;
+ Flag)
+- if [[ $line =~ \[nocfg\] || $line =~ \[global\] ]] ; then
++ if [[ $line =~ \[nocfg\] || $line =~ \[global\] || $key =~ --no- ]] ; then
+ _allkeys="$_allkeys $key"
+ else
+ _allkeys="$_allkeys ${key}="
diff --git a/app-shells/mpv-bash-completion/metadata.xml b/app-shells/mpv-bash-completion/metadata.xml
new file mode 100644
index 000000000000..4d854b688c36
--- /dev/null
+++ b/app-shells/mpv-bash-completion/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>itumaykin+gentoo@gmail.com</email>
+ <name>Coacher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">2ion/mpv-bash-completion</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-0.16.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-0.16.ebuild
new file mode 100644
index 000000000000..aa2471de6fa5
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-0.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ media-video/mpv[cli]
+ !<app-shells/bash-4
+"
+RDEPEND="${DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-no-flag-options-completion.patch" )
+
+src_compile() {
+ "${S}"/gen.sh > ${PN} || die
+}
+
+src_install() {
+ default
+ newbashcomp ${PN} mpv
+}