summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-07 16:11:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-07 16:57:41 +0200
commitf032399d2703c2c708d886c6ada3a070da36e538 (patch)
treef27d663fd968a08675f9eec6086550cadc822a5b /app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
parentapp-office/denaro: new package; add 2023.9.2 (diff)
downloadgentoo-f032399d2703c2c708d886c6ada3a070da36e538.tar.gz
gentoo-f032399d2703c2c708d886c6ada3a070da36e538.tar.bz2
gentoo-f032399d2703c2c708d886c6ada3a070da36e538.zip
app-shells/posh-dotnet: new package; add 1.2.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild')
-rw-r--r--app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild b/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
new file mode 100644
index 000000000000..f0151f7e8666
--- /dev/null
+++ b/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell tab completion and tooltip support for the dotnet CLI"
+HOMEPAGE="https://github.com/bergmeister/posh-dotnet/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/bergmeister/${PN}.git"
+else
+ if [[ "${PV}" == 1.2.3 ]] ; then
+ COMMIT="c017886cbad9c4f6ce1fbaa38ebbbcada664655b"
+
+ SRC_URI="https://github.com/bergmeister/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ SRC_URI="https://github.com/bergmeister/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ fi
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="${PV}"
+RESTRICT="test" # Tests fail.
+
+RDEPEND="virtual/pwsh:*"
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins "${PN}.psd1" "${PN}.psm1"
+
+ einstalldocs
+}