summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-01-22 23:41:55 +1300
committerKent Fredric <kentnl@gentoo.org>2017-01-22 23:44:19 +1300
commit95e18c72344745e8f9c89c1737b92d0a3a45fbc7 (patch)
tree9d845e8fdc4084c0cb11a052db9626bf064603a3 /app-shells/psh/psh-1.8.1-r3.ebuild
parentapp-shells/psh: Fix dead HOMEPAGE (diff)
downloadgentoo-95e18c72344745e8f9c89c1737b92d0a3a45fbc7.tar.gz
gentoo-95e18c72344745e8f9c89c1737b92d0a3a45fbc7.tar.bz2
gentoo-95e18c72344745e8f9c89c1737b92d0a3a45fbc7.zip
app-shells/psh: -r3 bump to use Github for SRC_URI + Fixes
- EAPI6 - Use Github instead of dead mirror - Fix some basic bugs Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-shells/psh/psh-1.8.1-r3.ebuild')
-rw-r--r--app-shells/psh/psh-1.8.1-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/psh/psh-1.8.1-r3.ebuild b/app-shells/psh/psh-1.8.1-r3.ebuild
new file mode 100644
index 000000000000..71fd3cea35f8
--- /dev/null
+++ b/app-shells/psh/psh-1.8.1-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+DIST_EXAMPLES=( "examples/*" )
+
+inherit perl-module
+
+DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
+HOMEPAGE="https://gnp.github.io/psh/"
+SRC_URI="https://github.com/gnp/psh/archive/${P}.tar.gz -> ${PF}.tar.gz"
+S="${WORKDIR}/${PN}-${P}" # github--
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="readline"
+
+RDEPEND="
+ readline? (
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/TermReadKey
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+myinst="SITEPREFIX=${D}/usr"
+
+PATCHES=(
+ "${FILESDIR}/${PF}-defined-array.patch"
+ "${FILESDIR}/${PF}-array-ref-deprecated.patch"
+)
+
+src_install() {
+ perl-module_src_install
+ docompress -x "/usr/share/doc/${PF}/pod"
+ docinto pod/
+ dodoc -r doc/*
+}