summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-12 23:25:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-12 23:25:22 +0200
commit3996629cd3e9f71bf44f03e8a59529d7e740f1a7 (patch)
tree4064f680a22ca8e134bd7042a4546e82e2bce55a /app-shells/rush/rush-2.1.ebuild
parentdev-python/django-taggit: 1.1.0 bump (diff)
downloadgentoo-3996629cd3e9f71bf44f03e8a59529d7e740f1a7.tar.gz
gentoo-3996629cd3e9f71bf44f03e8a59529d7e740f1a7.tar.bz2
gentoo-3996629cd3e9f71bf44f03e8a59529d7e740f1a7.zip
app-shells/rush: Bump to version 2.1
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells/rush/rush-2.1.ebuild')
-rw-r--r--app-shells/rush/rush-2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-shells/rush/rush-2.1.ebuild b/app-shells/rush/rush-2.1.ebuild
new file mode 100644
index 000000000000..cabf20f3885d
--- /dev/null
+++ b/app-shells/rush/rush-2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restricted User Shell"
+HOMEPAGE="https://puszcza.gnu.org.ua/projects/rush/"
+SRC_URI="ftp://download.gnu.org.ua/pub/release/${PN}/${P}.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="nls"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+# Testsuite doesn't like our sandbox (bug #689554)
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}