summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zapparov <alexey@zapparov.com>2022-12-21 23:34:19 +0100
committerSam James <sam@gentoo.org>2022-12-24 07:15:59 +0000
commit0fae67e5cc0997c5425fcc37f74e7c1008a17c52 (patch)
tree10db467a379f45d89b369fe3105bc43de7b65873 /app-shells/starship
parentapp-shells/starship: revbump 1.11.0-r1 (diff)
downloadgentoo-0fae67e5cc0997c5425fcc37f74e7c1008a17c52.tar.gz
gentoo-0fae67e5cc0997c5425fcc37f74e7c1008a17c52.tar.bz2
gentoo-0fae67e5cc0997c5425fcc37f74e7c1008a17c52.zip
app-shells/starship: revbump 1.10.3-r1
Bug: https://bugs.gentoo.org/864034 Signed-off-by: Alexey Zapparov <alexey@zapparov.com> Closes: https://github.com/gentoo/gentoo/pull/28749 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/starship')
-rw-r--r--app-shells/starship/files/starship-1.10.3-no-old-time.patch109
-rw-r--r--app-shells/starship/starship-1.10.3-r1.ebuild (renamed from app-shells/starship/starship-1.10.3.ebuild)2
2 files changed, 111 insertions, 0 deletions
diff --git a/app-shells/starship/files/starship-1.10.3-no-old-time.patch b/app-shells/starship/files/starship-1.10.3-no-old-time.patch
new file mode 100644
index 000000000000..bbeca72ae24a
--- /dev/null
+++ b/app-shells/starship/files/starship-1.10.3-no-old-time.patch
@@ -0,0 +1,109 @@
+From 17dfab50cf27e0023286dcee58810b91906cf1aa Mon Sep 17 00:00:00 2001
+From: Alexey Zapparov <alexey@zapparov.com>
+Date: Wed, 21 Dec 2022 23:31:59 +0100
+Subject: [PATCH] Remove time-0.1.x dependency
+
+Bug: https://bugs.gentoo.org/864034
+See: RUSTSEC-2020-0071 <https://rustsec.org/advisories/RUSTSEC-2020-0071>
+See: Upstream Fix Proposal <https://github.com/starship/starship/pull/4750>
+Signed-off-by: Alexey Zapparov <alexey@zapparov.com>
+---
+ Cargo.lock | 26 ++++----------------------
+ Cargo.toml | 2 +-
+ 2 files changed, 5 insertions(+), 23 deletions(-)
+
+diff --git a/Cargo.lock b/Cargo.lock
+index 010862b3..60b965c0 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -306,7 +306,6 @@ dependencies = [
+ "js-sys",
+ "num-integer",
+ "num-traits",
+- "time 0.1.44",
+ "wasm-bindgen",
+ "winapi",
+ ]
+@@ -981,7 +980,7 @@ checksum = "1d58ccaaf783384a6ad68a6abf84942a3f88e34970ced3b34dc68183be50996d"
+ dependencies = [
+ "bstr",
+ "itoa",
+- "time 0.3.14",
++ "time",
+ ]
+
+ [[package]]
+@@ -1584,7 +1583,7 @@ dependencies = [
+ "dirs-next",
+ "objc-foundation",
+ "objc_id",
+- "time 0.3.14",
++ "time",
+ ]
+
+ [[package]]
+@@ -2585,7 +2584,7 @@ checksum = "8c0ea0c68418544f725eba5401a5b965a2263254c92458d04aeae74e9d88ff4e"
+ dependencies = [
+ "const_format",
+ "is_debug",
+- "time 0.3.14",
++ "time",
+ ]
+
+ [[package]]
+@@ -2793,7 +2792,7 @@ dependencies = [
+ "lazy_static",
+ "libc",
+ "nom 7.1.1",
+- "time 0.3.14",
++ "time",
+ "winapi",
+ ]
+
+@@ -2919,17 +2918,6 @@ dependencies = [
+ "syn",
+ ]
+
+-[[package]]
+-name = "time"
+-version = "0.1.44"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "6db9e6914ab8b1ae1c260a4ae7a49b6c5611b40328a735b21862567685e73255"
+-dependencies = [
+- "libc",
+- "wasi 0.10.0+wasi-snapshot-preview1",
+- "winapi",
+-]
+-
+ [[package]]
+ name = "time"
+ version = "0.3.14"
+@@ -3195,12 +3183,6 @@ version = "0.9.0+wasi-snapshot-preview1"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "cccddf32554fecc6acb585f82a32a72e28b48f8c4c1883ddfeeeaa96f7d8e519"
+
+-[[package]]
+-name = "wasi"
+-version = "0.10.0+wasi-snapshot-preview1"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "1a143597ca7c7793eff794def352d41792a93c481eb1042423ff7ff72ba2c31f"
+-
+ [[package]]
+ name = "wasi"
+ version = "0.11.0+wasi-snapshot-preview1"
+diff --git a/Cargo.toml b/Cargo.toml
+index 2fccbe11..8af05383 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -35,7 +35,7 @@ config-schema = ["schemars"]
+ notify = ["notify-rust"]
+
+ [dependencies]
+-chrono = { version = "0.4.22", features = ["clock", "std"] }
++chrono = { version = "0.4.22", default-features = false, features = ["clock", "std", "wasmbind"] }
+ clap = { version = "=3.2.20", features = ["derive", "cargo", "unicode", "unstable-v4"] }
+ clap_complete = "3.2.4"
+ dirs-next = "2.0.0"
+--
+2.38.2
+
diff --git a/app-shells/starship/starship-1.10.3.ebuild b/app-shells/starship/starship-1.10.3-r1.ebuild
index bc533b456e59..2b928766582c 100644
--- a/app-shells/starship/starship-1.10.3.ebuild
+++ b/app-shells/starship/starship-1.10.3-r1.ebuild
@@ -392,6 +392,8 @@ BDEPEND=">=virtual/rust-1.59"
PATCHES=(
# https://bugs.gentoo.org/866133
"${FILESDIR}"/${PN}-1.10.3-no-strip.patch
+ # https://bugs.gentoo.org/864034
+ "${FILESDIR}"/${PN}-1.10.3-no-old-time.patch
)
QA_FLAGS_IGNORED="usr/bin/starship"