summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandy Barlow <randy@electronsweatshop.com>2022-10-01 13:56:50 -0400
committerSam James <sam@gentoo.org>2022-10-04 14:44:27 +0100
commit7d2c1bb3a36099d955b8cede5afb961f227b1860 (patch)
tree7bed1ad33f69acef6f863869f98b05bfbebec9ff /app-shells/starship
parentapp-shells/starship: Filter LTO flags (diff)
downloadgentoo-7d2c1bb3a36099d955b8cede5afb961f227b1860.tar.gz
gentoo-7d2c1bb3a36099d955b8cede5afb961f227b1860.tar.bz2
gentoo-7d2c1bb3a36099d955b8cede5afb961f227b1860.zip
app-shells/starship: Do not strip executable
Closes: https://bugs.gentoo.org/866133 Signed-off-by: Randy Barlow <randy@electronsweatshop.com> Closes: https://github.com/gentoo/gentoo/pull/27561 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/starship')
-rw-r--r--app-shells/starship/files/starship-1.10.3-no-strip.patch27
-rw-r--r--app-shells/starship/starship-1.10.3.ebuild5
2 files changed, 32 insertions, 0 deletions
diff --git a/app-shells/starship/files/starship-1.10.3-no-strip.patch b/app-shells/starship/files/starship-1.10.3-no-strip.patch
new file mode 100644
index 000000000000..f5a548f04a47
--- /dev/null
+++ b/app-shells/starship/files/starship-1.10.3-no-strip.patch
@@ -0,0 +1,27 @@
+From 637ef935b0a4f60524a0c0ce034317f2dee04b78 Mon Sep 17 00:00:00 2001
+From: Randy Barlow <randy@electronsweatshop.com>
+Date: Sat, 1 Oct 2022 13:52:53 -0400
+Subject: [PATCH] Do not strip executable
+
+This should be a choice for the user.
+
+Signed-off-by: Randy Barlow <randy@electronsweatshop.com>
+---
+ Cargo.toml | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Cargo.toml b/Cargo.toml
+index 2fccbe11..4595c33f 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -123,7 +123,6 @@ tempfile = "3.2.0"
+ [profile.release]
+ codegen-units = 1
+ lto = true
+-strip = true
+
+ [[bin]]
+ name = "starship"
+--
+2.37.3
+
diff --git a/app-shells/starship/starship-1.10.3.ebuild b/app-shells/starship/starship-1.10.3.ebuild
index 2b91c3a58414..94efc12ef8ab 100644
--- a/app-shells/starship/starship-1.10.3.ebuild
+++ b/app-shells/starship/starship-1.10.3.ebuild
@@ -389,6 +389,11 @@ KEYWORDS="~amd64"
BDEPEND=">=virtual/rust-1.59"
+PATCHES=(
+ # https://bugs.gentoo.org/866133
+ "${FILESDIR}"/${PN}-1.10.3-no-strip.patch
+)
+
QA_FLAGS_IGNORED="usr/bin/starship"
src_configure() {