summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-03 07:21:03 +0000
committerSam James <sam@gentoo.org>2020-12-03 07:21:25 +0000
commitbc660ab7669eecffca30e4ac7b11cd5e775da161 (patch)
tree0e39ddefc2801795b135f148a2c6e417b96746f6 /app-shells/thefuck/thefuck-3.30.ebuild
parentapp-shells/thefuck: add Python 3.8, 3.9 (diff)
downloadgentoo-bc660ab7669eecffca30e4ac7b11cd5e775da161.tar.gz
gentoo-bc660ab7669eecffca30e4ac7b11cd5e775da161.tar.bz2
gentoo-bc660ab7669eecffca30e4ac7b11cd5e775da161.zip
app-shells/thefuck: bump to 3.30
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/thefuck/thefuck-3.30.ebuild')
-rw-r--r--app-shells/thefuck/thefuck-3.30.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/thefuck/thefuck-3.30.ebuild b/app-shells/thefuck/thefuck-3.30.ebuild
new file mode 100644
index 000000000000..ffcc66f3c8af
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.30.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -vv || die
+}