summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-16 17:24:36 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-16 17:24:36 +0100
commit8eaa173a418440c89426a3ab7650751e94faf7b0 (patch)
tree4c5b4da854260c8e137b43d4cab24009d39652df /app-shells/zsh-completions/zsh-completions-0.23.0.ebuild
parentnet-im/mcabber: version bump, fixes bug #608800 / CVE-2017-5604 (diff)
downloadgentoo-8eaa173a418440c89426a3ab7650751e94faf7b0.tar.gz
gentoo-8eaa173a418440c89426a3ab7650751e94faf7b0.tar.bz2
gentoo-8eaa173a418440c89426a3ab7650751e94faf7b0.zip
app-shells/zsh-completions: Version bump to 0.23.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-shells/zsh-completions/zsh-completions-0.23.0.ebuild')
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.23.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/zsh-completions-0.23.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.23.0.ebuild
new file mode 100644
index 000000000000..35340b072e0f
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.23.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}