summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-10-28 17:00:32 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-10-28 17:00:32 +0100
commit29da512733cfaa66d33ad2a052b65e8d406e47f8 (patch)
tree56f5dce2d598eadd341af05b7d4fc0ad5b19f62a /app-shells/zsh-completions/zsh-completions-0.29.0.ebuild
parentdev-libs/g-wrap: remove old 1.9.11 (diff)
downloadgentoo-29da512733cfaa66d33ad2a052b65e8d406e47f8.tar.gz
gentoo-29da512733cfaa66d33ad2a052b65e8d406e47f8.tar.bz2
gentoo-29da512733cfaa66d33ad2a052b65e8d406e47f8.zip
app-shells/zsh-completions: Version bump to 0.29.0
Signed-off-by: Manuel Rüger <mrueg@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-shells/zsh-completions/zsh-completions-0.29.0.ebuild')
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.29.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/zsh-completions-0.29.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.29.0.ebuild
new file mode 100644
index 000000000000..926c471ffa08
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.29.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~sparc ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}