summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-03 03:44:03 +0100
committerSam James <sam@gentoo.org>2022-07-03 03:44:03 +0100
commitc57ab415de7fd0dfb3017f93b7105f144bca9e4d (patch)
tree34fcb2552fcaf3466c2df1d763e8f5d0e399ea1e /app-shells/zsh-completions
parentapp-portage/tatt: keyword ~s390 (diff)
downloadgentoo-c57ab415de7fd0dfb3017f93b7105f144bca9e4d.tar.gz
gentoo-c57ab415de7fd0dfb3017f93b7105f144bca9e4d.tar.bz2
gentoo-c57ab415de7fd0dfb3017f93b7105f144bca9e4d.zip
app-shells/zsh-completions: add 0.34.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/zsh-completions')
-rw-r--r--app-shells/zsh-completions/Manifest1
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.34.0.ebuild31
-rw-r--r--app-shells/zsh-completions/zsh-completions-9999.ebuild8
3 files changed, 35 insertions, 5 deletions
diff --git a/app-shells/zsh-completions/Manifest b/app-shells/zsh-completions/Manifest
index 5eb74798dedc..5de3a9af26ad 100644
--- a/app-shells/zsh-completions/Manifest
+++ b/app-shells/zsh-completions/Manifest
@@ -1 +1,2 @@
DIST zsh-completions-0.33.0.tar.gz 285049 BLAKE2B bcbbb2966a48f1b8c06e14f14432e147b4a4ca28c7d9769b4a108e3d4e005c37874c93c836c8636dabb860780077ccc5d9ebbd339f63c34fd16975ec5486a5c4 SHA512 8eaa7d9d2a58e8e2daa6ba7d9a8498e607b271bfd0484184482ec610e7f647ca72ba945f6897b2d619918304a18d048c4b079dae0993dc660cba61d4bce1e0a3
+DIST zsh-completions-0.34.0.tar.gz 304543 BLAKE2B 75afed3059e889f92843099ad3eddae1f939a7d9a46d87a8048c5742b44699c2da13a9c2ea00ca2ea02898472199f064c420aac8943338e3b22189a7cc0d23b4 SHA512 643e967a77ab708c6316a9b43edd8b411f133aa4abe10bf69d3f5e545b2128423ad80d3509e7f9077b30cb8a83f60fe8d4355ed0a697dadffe1e1aaac6597c04
diff --git a/app-shells/zsh-completions/zsh-completions-0.34.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.34.0.ebuild
new file mode 100644
index 000000000000..f5ebe5d49325
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.34.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="Apache-2.0 BSD MIT ZSH"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+}
diff --git a/app-shells/zsh-completions/zsh-completions-9999.ebuild b/app-shells/zsh-completions/zsh-completions-9999.ebuild
index ea096ae90a8d..f5ebe5d49325 100644
--- a/app-shells/zsh-completions/zsh-completions-9999.ebuild
+++ b/app-shells/zsh-completions/zsh-completions-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
else
SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
fi
DESCRIPTION="Additional completion definitions for Zsh"
@@ -25,9 +25,7 @@ src_install() {
}
pkg_postinst() {
- elog
elog "If you happen to compile your functions, you may need to delete"
elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
elog "to your shell."
- elog
}