summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-02 04:19:46 +0000
committerSam James <sam@gentoo.org>2022-12-02 21:09:48 +0000
commit02b17c9bb64e147affc4acecaa0ff4151b2329bf (patch)
tree2fc404197c16c76cdae2ecadb9c4390a77b5e4b7 /app-shells
parentsys-devel/flex: support app-alternatives/lex (diff)
downloadgentoo-02b17c9bb64e147affc4acecaa0ff4151b2329bf.tar.gz
gentoo-02b17c9bb64e147affc4acecaa0ff4151b2329bf.tar.bz2
gentoo-02b17c9bb64e147affc4acecaa0ff4151b2329bf.zip
Move {virtual -> app-alternatives}/yacc
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-4.2_p53.ebuild2
-rw-r--r--app-shells/bash/bash-4.3_p48-r2.ebuild2
-rw-r--r--app-shells/bash/bash-4.4_p23-r2.ebuild2
-rw-r--r--app-shells/bash/bash-5.0_p18.ebuild2
-rw-r--r--app-shells/bash/bash-5.1_p16-r2.ebuild2
-rw-r--r--app-shells/bash/bash-5.2_p12.ebuild2
-rw-r--r--app-shells/bash/bash-9999.ebuild2
7 files changed, 7 insertions, 7 deletions
diff --git a/app-shells/bash/bash-4.2_p53.ebuild b/app-shells/bash/bash-4.2_p53.ebuild
index e80e66616297..b5ae0c39892b 100644
--- a/app-shells/bash/bash-4.2_p53.ebuild
+++ b/app-shells/bash/bash-4.2_p53.ebuild
@@ -51,7 +51,7 @@ RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )"
# We only need yacc when the .y files get patched (bash42-005)
-BDEPEND="virtual/yacc"
+BDEPEND="app-alternatives/yacc"
S="${WORKDIR}/${MY_P}"
diff --git a/app-shells/bash/bash-4.3_p48-r2.ebuild b/app-shells/bash/bash-4.3_p48-r2.ebuild
index 4409129e3732..dcd165238d97 100644
--- a/app-shells/bash/bash-4.3_p48-r2.ebuild
+++ b/app-shells/bash/bash-4.3_p48-r2.ebuild
@@ -54,7 +54,7 @@ DEPEND=">=sys-libs/ncurses-5.2-r2:0=
RDEPEND="${DEPEND}
!<sys-apps/portage-2.1.6.7_p1"
# We only need yacc when the .y files get patched (bash42-005)
-BDEPEND="virtual/yacc"
+BDEPEND="app-alternatives/yacc"
PATCHES=(
"${WORKDIR}"/${P}-r2-patches/${PN}-4.3-mapfile-improper-array-name-validation.patch
diff --git a/app-shells/bash/bash-4.4_p23-r2.ebuild b/app-shells/bash/bash-4.4_p23-r2.ebuild
index 1cbb226099a8..3da92649f1d5 100644
--- a/app-shells/bash/bash-4.4_p23-r2.ebuild
+++ b/app-shells/bash/bash-4.4_p23-r2.ebuild
@@ -66,7 +66,7 @@ RDEPEND="
${DEPEND}
"
# We only need yacc when the .y files get patched (bash42-005)
-#BDEPEND="virtual/yacc"
+#BDEPEND="app-alternatives/yacc"
S="${WORKDIR}/${MY_P}"
diff --git a/app-shells/bash/bash-5.0_p18.ebuild b/app-shells/bash/bash-5.0_p18.ebuild
index 55781d0923c2..84c1ac19288a 100644
--- a/app-shells/bash/bash-5.0_p18.ebuild
+++ b/app-shells/bash/bash-5.0_p18.ebuild
@@ -66,7 +66,7 @@ RDEPEND="
${DEPEND}
"
# We only need yacc when the .y files get patched (bash42-005)
-#BDEPEND="virtual/yacc"
+#BDEPEND="app-alternatives/yacc"
S="${WORKDIR}/${MY_P}"
diff --git a/app-shells/bash/bash-5.1_p16-r2.ebuild b/app-shells/bash/bash-5.1_p16-r2.ebuild
index 54d56596e605..eda4291bf8b7 100644
--- a/app-shells/bash/bash-5.1_p16-r2.ebuild
+++ b/app-shells/bash/bash-5.1_p16-r2.ebuild
@@ -85,7 +85,7 @@ RDEPEND="
${DEPEND}
"
# We only need yacc when the .y files get patched (bash42-005, bash51-011)
-BDEPEND="virtual/yacc
+BDEPEND="app-alternatives/yacc
verify-sig? ( sec-keys/openpgp-keys-chetramey )"
S="${WORKDIR}/${MY_P}"
diff --git a/app-shells/bash/bash-5.2_p12.ebuild b/app-shells/bash/bash-5.2_p12.ebuild
index 955033674b60..96a742ef63a7 100644
--- a/app-shells/bash/bash-5.2_p12.ebuild
+++ b/app-shells/bash/bash-5.2_p12.ebuild
@@ -93,7 +93,7 @@ RDEPEND="
"
# We only need yacc when the .y files get patched (bash42-005, bash51-011)
BDEPEND="
- virtual/yacc
+ app-alternatives/yacc
pgo? ( dev-util/gperf )
verify-sig? ( sec-keys/openpgp-keys-chetramey )
"
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index f679e4cd77dc..6f6be5e13621 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -92,7 +92,7 @@ RDEPEND="
${DEPEND}
"
# We only need yacc when the .y files get patched (bash42-005, bash51-011)
-#BDEPEND="virtual/yacc"
+#BDEPEND="app-alternatives/yacc"
BDEPEND="
pgo? ( dev-util/gperf )
verify-sig? ( sec-keys/openpgp-keys-chetramey )