summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-05-18 13:34:44 +0200
committerFabian Groffen <grobian@gentoo.org>2021-05-18 13:35:10 +0200
commit0cbe880a5806bcf88d459f0527b1517081d4db98 (patch)
tree6e107c12c1afa18b74c0f304265e5ba981736009 /app-shells
parentnet-proxy/haproxy: SLZ is no longer an external dependency (diff)
downloadgentoo-0cbe880a5806bcf88d459f0527b1517081d4db98.tar.gz
gentoo-0cbe880a5806bcf88d459f0527b1517081d4db98.tar.bz2
gentoo-0cbe880a5806bcf88d459f0527b1517081d4db98.zip
app-shells/tcsh-6.2104: version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/tcsh/Manifest1
-rw-r--r--app-shells/tcsh/files/tcsh-6.21.04-no-nls.patch18
-rw-r--r--app-shells/tcsh/tcsh-6.22.04.ebuild103
3 files changed, 122 insertions, 0 deletions
diff --git a/app-shells/tcsh/Manifest b/app-shells/tcsh/Manifest
index e7de9ecf0e8f..a8941cee354e 100644
--- a/app-shells/tcsh/Manifest
+++ b/app-shells/tcsh/Manifest
@@ -1,2 +1,3 @@
DIST tcsh-6.22.02.tar.gz 1006405 BLAKE2B f18b2c48958b4d38a0f55b0df8563564b2a3b34becf02eda8802d7f5e2194082bf96c46323d606c2e6bd2a26aaed303bae3132d03515274407c63b713583dde7 SHA512 32d271b568c63265ea4c98494f5e60b37c3a3fc2594e8763b8f6f0b09018ab9db7ef6f951120b37f7880ccf04ba3a2559e30dc08d24f4ba9dc36853238d55980
+DIST tcsh-6.22.04.tar.gz 1012977 BLAKE2B 5702e17e25603a244e4481294cbe2dc2272d4f3ac8362be9e1dd65f3857e0e54520a245d321dda5ef747345776c22068dcb130705daddf71cb650b154ed96ba4 SHA512 3956df52124d496dc0e67e4e3e801787f31690f96a60399953e401648d5b4cfb06baa9833c32cb771177b3e89b7a27e5765534db073206568fe773598a55e873
DIST tcsh-gentoo-patches-r1.9.tar.bz2 2488 BLAKE2B 58924e623c75068cdc686be61755bdbcf8d0949a2141ac532ac089f80ff083b2c9f6767038b9fc52171a00ed82c558b83216327c87b41f51c3648343869cd5b6 SHA512 9903e9c3e2279abcac09a3235f3c5db9f42156c18137eb651ede195ca2b069f0b5bc6105fed33666b69796c4ebf03e4efe63cd9beba1898bac7297a2f74bfd3d
diff --git a/app-shells/tcsh/files/tcsh-6.21.04-no-nls.patch b/app-shells/tcsh/files/tcsh-6.21.04-no-nls.patch
new file mode 100644
index 000000000000..7f465d8a75ef
--- /dev/null
+++ b/app-shells/tcsh/files/tcsh-6.21.04-no-nls.patch
@@ -0,0 +1,18 @@
+GetCmdChar: fix compilation with --disable-nls
+
+Bug: https://bugs.gentoo.org/689904
+
+--- a/ed.inputl.c
++++ b/ed.inputl.c
+@@ -668,9 +668,9 @@
+ GetCmdChar(Char ch)
+ {
+ #ifndef WINNT_NATIVE // We use more than 256 for various extended keys
+- wint_t c = ch & CHAR;
++ eChar c = ch & CHAR;
+ #else
+- wint_t c = ch;
++ eChar c = ch;
+ #endif
+ return c < NT_NUM_KEYS ? CurrentKeyMap[c] : F_INSERT;
+ }
diff --git a/app-shells/tcsh/tcsh-6.22.04.ebuild b/app-shells/tcsh/tcsh-6.22.04.ebuild
new file mode 100644
index 000000000000..3ce4f1d44b2e
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.22.04.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic autotools prefix
+
+CONFVER="1.9"
+
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="https://www.tcsh.org/"
+SRC_URI="
+ ftp://ftp.astron.com/pub/tcsh/${P}.tar.gz
+ https://dev.gentoo.org/~grobian/distfiles/tcsh-gentoo-patches-r${CONFVER}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls doc"
+RESTRICT="test"
+
+# we need gettext because we run autoconf (AM_ICONV)
+RDEPEND="
+ >=sys-libs/ncurses-5.1:0=
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-lang/perl )"
+
+CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.20.00-debian-dircolors.patch # bug #120792
+ "${FILESDIR}"/${PN}-6.21.04-no-nls.patch
+ "${FILESDIR}"/${PN}-6.21.00-use-ncurses.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ # fix gencat usage
+ sed \
+ -e 's/cat \$\^ \$> | \$(GENCAT) \$@/rm -f $@; $(GENCAT) $@ $> $^/' \
+ -i nls/Makefile.in || die
+
+ # always use sysmalloc, the builtin malloc fails on Darwin, musl,
+ # etc. it's already used for glibc-linux, so this doesn't change
+ # anything for the majority of users
+ sed -i -e 's/undef SYSMALLOC/define SYSMALLOC/' config_f.h || die
+
+ # unify ECHO behaviour
+ echo "#undef ECHO_STYLE" >> config_f.h
+ echo "#define ECHO_STYLE BOTH_ECHO" >> config_f.h
+
+ eprefixify "${CONFDIR}"/*
+ # activate the right default PATH
+ if [[ -z ${EPREFIX} ]] ; then
+ sed -i \
+ -e 's/^#MAIN//' -e '/^#PREFIX/d' \
+ "${CONFDIR}"/csh.login || die
+ else
+ sed -i \
+ -e 's/^#PREFIX//' -e '/^#MAIN/d' \
+ "${CONFDIR}"/csh.login || die
+ fi
+
+ eapply_user
+}
+
+src_configure() {
+ # make tcsh look and live along the lines of the prefix
+ append-cppflags -D_PATH_DOTCSHRC="'"'"${EPREFIX}/etc/csh.cshrc"'"'"
+ append-cppflags -D_PATH_DOTLOGIN="'"'"${EPREFIX}/etc/csh.login"'"'"
+ append-cppflags -D_PATH_DOTLOGOUT="'"'"${EPREFIX}/etc/csh.logout"'"'"
+ append-cppflags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
+ append-cppflags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
+
+ econf \
+ --prefix="${EPREFIX:-}" \
+ --datarootdir='${prefix}/usr/share' \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man
+
+ DOCS=( FAQ Fixes NewThings Ported README.md WishList Y2K )
+ if use doc ; then
+ perl tcsh.man2html tcsh.man || die
+ HTML_DOCS=( tcsh.html/*.html )
+ fi
+ einstalldocs
+
+ insinto /etc
+ doins \
+ "${CONFDIR}"/csh.cshrc \
+ "${CONFDIR}"/csh.login
+
+ # bug #119703: add csh -> tcsh symlink
+ dosym tcsh /bin/csh
+}