summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-23 16:04:07 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-23 16:06:45 -0700
commit275e4e3410263dfe5ac0fdcd16b3bf7037c12b4b (patch)
tree99712b84c18bcad737056d2f608bd9188083d2de /app-shells
parentsys-devel/gcc: cut 1.4 patchset for 4.0.4 (diff)
downloadgentoo-275e4e3410263dfe5ac0fdcd16b3bf7037c12b4b.tar.gz
gentoo-275e4e3410263dfe5ac0fdcd16b3bf7037c12b4b.tar.bz2
gentoo-275e4e3410263dfe5ac0fdcd16b3bf7037c12b4b.zip
app-shells/fzy: bump to 1.0
Now with proper UTF8 support. Change dvtm/tmux script location to /usr/bin Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fzy/Manifest1
-rw-r--r--app-shells/fzy/fzy-1.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-shells/fzy/Manifest b/app-shells/fzy/Manifest
index 9aefd251ac68..787fc6bb5df4 100644
--- a/app-shells/fzy/Manifest
+++ b/app-shells/fzy/Manifest
@@ -1,2 +1,3 @@
DIST fzy-0.9.tar.gz 42992 BLAKE2B ebc7e73e0387101da65896a4108705048bb72b01261ea86a0abeaee22fe4517ac54351d508bb79419b05a15aa9c93c5d815c34d15353d01c02381e5d342e75b7 SHA512 71a44bc3bbef3a2d82476a69b5c9e28753e760bbb8d453a9e44b57f34a79dd8ebcd510a869dfeae95f522ba6ccb4b8f10f79c081ce6bc6cfae9a41f4071fefc0
+DIST fzy-1.0.tar.gz 47432 BLAKE2B 5fef7061c797e63dabc3f77daf3dbc8a58671c257430dc8ba4680363a9ace5722562fc7e0aba618d53820e703b261dbe0182638f16223d1202080450a6c21ec2 SHA512 de5ed1af035260f4ae550c53b08c4ff302c978350784cbfd2981d1691f55d9c0f26b9333c74adea939b3f4578dd47e66ee99112e10afc5497c64011827d19dbc
DIST fzy-2697c02618d908e5bdcae93ab4815b04c49bd25e.tar.gz 45814 BLAKE2B bb4dbc668dd93c71d16c3affdaf148212e3fbdef27110314b8145fd4a20991bb368f7aef1d1f7bd147afa23900800c468b4d9b2999de2226ce9a312a02d344b4 SHA512 34520dc3b4bcbad3479cce1fbeb014b1851edc1b1f4460c21a645297bf9ec01a1483f108a562f6ac6d3c0def97427740b74e9a3b83c85223d14ac3e1586e3d8e
diff --git a/app-shells/fzy/fzy-1.0.ebuild b/app-shells/fzy/fzy-1.0.ebuild
new file mode 100644
index 000000000000..ba77064dac01
--- /dev/null
+++ b/app-shells/fzy/fzy-1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils savedconfig toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jhawthorn/fzy.git"
+else
+ SRC_URI="https://github.com/jhawthorn/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Fuzzy text selector (interactive grep) for console"
+HOMEPAGE="https://github.com/jhawthorn/fzy"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}"/fzy-0.9-cflags.patch )
+
+src_prepare() {
+ default
+ restore_config config.h
+ tc-export CC
+}
+
+src_install() {
+ local DOCS=( ALGORITHM.md CHANGELOG.md README.md )
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dobin contrib/fzy-tmux
+ dobin contrib/fzy-dvtm
+ einstalldocs
+ save_config config.h
+}
+
+pkg_postinst() {
+ savedconfig_pkg_postinst
+ optfeature "opening search results in dvtm pane with provided ${EPREFIX}/usr/bin/fzy-dvtm" app-misc/dvtm
+ optfeature "opening search results in tmux pane with provided ${EPREFIX}/usr/bin/fzy-tmux" app-misc/tmux
+}