summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 21:40:03 +0000
committerSam James <sam@gentoo.org>2021-03-16 21:40:07 +0000
commit2f058cd858fd7cb3d7c025f698c6baefc6661a1c (patch)
tree35e15469a98a7f67c907cc309d6c57b66dae91c5 /app-shells
parentdev-libs/ntl: handle removing .la differently (diff)
downloadgentoo-2f058cd858fd7cb3d7c025f698c6baefc6661a1c.tar.gz
gentoo-2f058cd858fd7cb3d7c025f698c6baefc6661a1c.tar.bz2
gentoo-2f058cd858fd7cb3d7c025f698c6baefc6661a1c.zip
app-shells/pdsh: add 2.34
Switches to a fork. Thanks-to: orbea <orbea@riseup.net> Closes: https://bugs.gentoo.org/775593 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pdsh/Manifest1
-rw-r--r--app-shells/pdsh/files/pdsh-2.34-slibtool.patch20
-rw-r--r--app-shells/pdsh/pdsh-2.34.ebuild63
3 files changed, 84 insertions, 0 deletions
diff --git a/app-shells/pdsh/Manifest b/app-shells/pdsh/Manifest
index b3c5c819b87e..4e2aae205eb1 100644
--- a/app-shells/pdsh/Manifest
+++ b/app-shells/pdsh/Manifest
@@ -1 +1,2 @@
DIST pdsh-2.26.tar.bz2 490732 BLAKE2B 809a7ee0a1026e0cdaea8bf97c046a3a6e2994199dbbdb2cebe56de0393e8422a07e86f1ff60d6e750bf7279ccb43c03ea3aa4529b6fa6a34e3d77d90f0c3597 SHA512 3f15b3bb4fc2cff27a3b5d68de3e6cb74bb4001288a787763358a0641d0cc77c840b2c6641213ef31bc9d9d69cfe9531b25d7a9375630a5b008b1bcffbe95c0a
+DIST pdsh-2.34.tar.gz 215708 BLAKE2B dba626c66b9a17536fc02d8482b776d539ee680354326c821dc916735d1fc115226fcf22868407830245067cf45ddf9c997cd8c382b0dde0168d9ed6cb4fcc4d SHA512 2d4e090d97f6bad97ee1dbdf2ee29e4d9603edfd5c92a6935131ef7f7bbff797cceb8ad3a72e3d5995d3d5302eac985d129f4968e3fa6744785a3df2d0fda33c
diff --git a/app-shells/pdsh/files/pdsh-2.34-slibtool.patch b/app-shells/pdsh/files/pdsh-2.34-slibtool.patch
new file mode 100644
index 000000000000..1be0485b9c6a
--- /dev/null
+++ b/app-shells/pdsh/files/pdsh-2.34-slibtool.patch
@@ -0,0 +1,20 @@
+https://github.com/chaos/pdsh/pull/130
+https://bugs.gentoo.org/775593
+From 258de95760a46c6d4c84e904823425aa1a180211 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Tue, 16 Mar 2021 13:25:52 -0700
+Subject: [PATCH] build: Use LDADD instead of LDFLAGS for libcommon.la.
+--- a/src/pdsh/Makefile.am
++++ b/src/pdsh/Makefile.am
+@@ -16,9 +16,9 @@ else
+ MODULE_FLAGS = -export-dynamic $(AIX_PDSH_LDFLAGS) -ldl
+ endif
+
+-pdsh_LDADD = $(READLINE_LIBS)
+-pdsh_LDFLAGS = $(MODULE_LIBS) $(MODULE_FLAGS) \
++pdsh_LDADD = $(READLINE_LIBS) \
+ $(top_builddir)/src/common/libcommon.la
++pdsh_LDFLAGS = $(MODULE_LIBS) $(MODULE_FLAGS)
+
+ pdsh_inst_LDADD = $(pdsh_LDADD)
+ pdsh_inst_LDFLAGS = $(pdsh_LDFLAGS)
diff --git a/app-shells/pdsh/pdsh-2.34.ebuild b/app-shells/pdsh/pdsh-2.34.ebuild
new file mode 100644
index 000000000000..6fd3cd631503
--- /dev/null
+++ b/app-shells/pdsh/pdsh-2.34.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A high-performance, parallel remote shell utility"
+HOMEPAGE="https://github.com/chaos/pdsh"
+SRC_URI="https://github.com/chaos/pdsh/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt readline rsh test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ crypt? ( net-misc/openssh )
+ rsh? ( net-misc/netkit-rsh )
+ readline? ( sys-libs/readline:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-util/dejagnu )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.34-slibtool.patch"
+)
+
+pkg_setup() {
+ PDSH_MODULE_LIST="${PDSH_MODULE_LIST:-netgroup}"
+ MODULE_CONFIG=""
+
+ local m
+ local valid_modules=":xcpu:ssh:exec:qshell:genders:nodeupdown:mrsh:mqshell:dshgroups:netgroup:"
+
+ for m in ${PDSH_MODULE_LIST}; do
+ if [[ "${valid_modules}" == *:${m}:* ]]; then
+ MODULE_CONFIG="${MODULE_CONFIG} --with-${m}"
+ fi
+ done
+
+ elog "Building ${PF} with the following modules:"
+ elog " ${PDSH_MODULE_LIST}"
+ elog "This list can be changed in /etc/portage/make.conf by setting"
+ elog "PDSH_MODULE_LIST=\"module1 module2...\""
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf ${MODULE_CONFIG} \
+ --with-machines \
+ --enable-shared \
+ --disable-static \
+ $(use_with crypt ssh) \
+ $(use_with rsh) \
+ $(use_with readline)
+}