summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-02 08:20:14 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-03-02 08:23:44 +0100
commit3421b0b60699a685ba3e0b42dda5c4435f206794 (patch)
tree6b5326973320a883aafc92bbe1bd9240f6e629c9 /app-shells
parentapp-shells/fish: Bump to version 3.2.0 (diff)
downloadgentoo-3421b0b60699a685ba3e0b42dda5c4435f206794.tar.gz
gentoo-3421b0b60699a685ba3e0b42dda5c4435f206794.tar.bz2
gentoo-3421b0b60699a685ba3e0b42dda5c4435f206794.zip
app-shells/fish: Synced live ebuild
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/fish-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-shells/fish/fish-9999.ebuild b/app-shells/fish/fish-9999.ebuild
index a23370890b1d..e2662c513ae4 100644
--- a/app-shells/fish/fish-9999.ebuild
+++ b/app-shells/fish/fish-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit cmake python-any-r1 readme.gentoo-r1
@@ -17,8 +17,8 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/${PN}-shell/${PN}-shell.git"
else
- SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+ SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -33,7 +33,8 @@ RDEPEND="
sys-libs/ncurses:0=[unicode]
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
nls? ( sys-devel/gettext )
test? (
${PYTHON_DEPS}