summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-01-16 13:56:57 -0500
committerBrian Evans <grknight@gentoo.org>2017-01-16 14:01:57 -0500
commit3b1a5445c90066d5758d9352a1a8c422e335ee0b (patch)
tree6ecdcbce23a44c8946616380314af2b2af60d9c5 /app-shells
parentapp-shells/quoter: Version bump (diff)
downloadgentoo-3b1a5445c90066d5758d9352a1a8c422e335ee0b.tar.gz
gentoo-3b1a5445c90066d5758d9352a1a8c422e335ee0b.tar.bz2
gentoo-3b1a5445c90066d5758d9352a1a8c422e335ee0b.zip
app-shells/push: Version bump
Non-maintainer commit. Ack by axs in IRC Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/push/Manifest1
-rw-r--r--app-shells/push/push-2.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/app-shells/push/Manifest b/app-shells/push/Manifest
index e88c7d3744e3..f053d22eee57 100644
--- a/app-shells/push/Manifest
+++ b/app-shells/push/Manifest
@@ -1,3 +1,4 @@
DIST push-1.11.tar.gz 2037 SHA256 04a141b4de60f20a328b0e410f12b277b017369fbf3143822bf59788cbd904d5 SHA512 f94ad1f8ebbebb0235617a7f3305f68872ad1a2f03edba6848dafe6b19161b93677417fd8bd5681f329b28a3f0edecbae783e7c162da900c9215313495f49490 WHIRLPOOL 4f625324fb73137a645e8534187de3f35e2b3d2f242dc5417f9d161eeb04f81124156d88e582211505be596ac902ebe36e3598e393275cbee78464cf9d35d12e
DIST push-1.6.tar.gz 1955 SHA256 713dea172ede55971ff82da932782503c2aa6703eba73c1ac317ec4c8eb22e80 SHA512 4623f51249138bacb7251fb5d5d1ae8dd070de7ce628e42b6eed90a4b6ffd36d28eb58b116f5b1833bc1affa8db539da9b94d104ffe03c6bd1e294b56c393c86 WHIRLPOOL 787f65542e92fd10c411969d03ec17b45a90b35e9c8e17b9fb3e732fb1d97813f04c3a03cc329a469a5bea2a194f879f4c600e2e534dd8c778f7f712d4c171b1
DIST push-1.8.tar.gz 1942 SHA256 99ae56c932b59b8b74c6a6d0972dfe5b65458d6871581168918264c5aa50bdbd SHA512 518568fc72d161d3abaea0a0c529d94fc9ad6dc46d18d300990de1367617e095befb8436e69267ebc11bd4dcbbbd9bca6375fc184666e442af6e2eaa68a992e5 WHIRLPOOL 5a763560b8afd4593aa1d0afc8f3ed5b053041c63d5aa742e485c25046191e8c733cdaf265117e23726c2c7cc8aeb87d3858a6228932192c2ee87ff4682e626d
+DIST push-2.0.tar.gz 2211 SHA256 2d5e1c5b580f77ac9fb65b7b75c6220ee88687b6e7340ccc746e42e5632604b0 SHA512 03c40bd8b3b09473952ecf13edd622533616de47638741214b40856b33993f9310d62be34fac6f68b950f58167c3111082554961a800a43a3ecf8a7d138ffdff WHIRLPOOL 6abbad060edbb3d9873c24b73bc61f38f6a4fd38633021e66f8d3a5a04b61dfcdec4c68afed5e8fe06f817cf924adfafb439ddb415c71fc4e1b52ce561ec6fa1
diff --git a/app-shells/push/push-2.0.ebuild b/app-shells/push/push-2.0.ebuild
new file mode 100644
index 000000000000..8b5a45b9ec1e
--- /dev/null
+++ b/app-shells/push/push-2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args"
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ dobin bin/push.sh
+ dodoc README
+}