summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-14 08:24:45 +0100
committerSam James <sam@gentoo.org>2023-05-14 08:26:40 +0100
commit5086fec5beec7570a9b9944998170df04f6c589a (patch)
tree367ac38875c09d21b42a4be256a46113f0382ae8 /app-shells
parentdev-libs/libpcre: add Valgrind annotation support ... (diff)
downloadgentoo-5086fec5beec7570a9b9944998170df04f6c589a.tar.gz
gentoo-5086fec5beec7570a9b9944998170df04f6c589a.tar.bz2
gentoo-5086fec5beec7570a9b9944998170df04f6c589a.zip
app-shells/zsh: add Valgrind annotation support
The headers are needed to get Valgrind annotations. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/metadata.xml3
-rw-r--r--app-shells/zsh/zsh-5.9-r4.ebuild4
2 files changed, 6 insertions, 1 deletions
diff --git a/app-shells/zsh/metadata.xml b/app-shells/zsh/metadata.xml
index b9eedff38fba..e61b8484dfcf 100644
--- a/app-shells/zsh/metadata.xml
+++ b/app-shells/zsh/metadata.xml
@@ -11,6 +11,9 @@
and tcsh were incorporated into zsh; many original features were
added.
</longdescription>
+ <use>
+ <flag name="valgrind">Support Valgrind (<pkg>dev-util/valgrind</pkg>) with annotations to improve results for memcheck.</flag>
+ </use>
<upstream>
<remote-id type="sourceforge">zsh</remote-id>
</upstream>
diff --git a/app-shells/zsh/zsh-5.9-r4.ebuild b/app-shells/zsh/zsh-5.9-r4.ebuild
index a97542cb1bca..6d24edfd9cd9 100644
--- a/app-shells/zsh/zsh-5.9-r4.ebuild
+++ b/app-shells/zsh/zsh-5.9-r4.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="https://www.zsh.org/"
LICENSE="ZSH gdbm? ( GPL-2 )"
SLOT="0"
-IUSE="caps debug doc examples gdbm maildir pcre static"
+IUSE="caps debug doc examples gdbm maildir pcre static valgrind"
RDEPEND="
>=sys-libs/ncurses-5.1:0=
@@ -36,6 +36,7 @@ RDEPEND="
)
"
DEPEND="sys-apps/groff
+ valgrind? ( dev-util/valgrind )
${RDEPEND}"
PDEPEND="
examples? ( app-doc/zsh-lovers )
@@ -92,6 +93,7 @@ src_configure() {
$(use_enable pcre)
$(use_enable caps cap)
$(use_enable gdbm)
+ $(use_enable valgrind zsh-valgrind)
)
if use static ; then