summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-11 20:37:44 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-11 20:37:44 +0100
commit512a302d75d91952fc441e5d3ac20fe000cbc6d9 (patch)
tree716ecbc8952c6de534b935ec2761c45502979aea /app-shells
parentmeson.eclass: change '--host-route' to '--host-root' (diff)
downloadgentoo-512a302d75d91952fc441e5d3ac20fe000cbc6d9.tar.gz
gentoo-512a302d75d91952fc441e5d3ac20fe000cbc6d9.tar.bz2
gentoo-512a302d75d91952fc441e5d3ac20fe000cbc6d9.zip
app-shells/dash: Security cleanup
Bug: https://bugs.gentoo.org/754267 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/Manifest1
-rw-r--r--app-shells/dash/dash-0.5.11.2.ebuild57
-rw-r--r--app-shells/dash/dash-0.5.11.3.ebuild57
3 files changed, 0 insertions, 115 deletions
diff --git a/app-shells/dash/Manifest b/app-shells/dash/Manifest
index 0decddc34b40..f34f75bc2620 100644
--- a/app-shells/dash/Manifest
+++ b/app-shells/dash/Manifest
@@ -1,2 +1 @@
-DIST dash-0.5.11.2.tar.gz 244475 BLAKE2B 4edc85a70af62684b29fec7fd9c599aaade38ffcfb62b873dd149c4ada9e750f24cddf9a390c512313bc7dde67cab3d7b57776c92fe5f8e08bf8bdc164a4e5ec SHA512 2f846c26f3722ea3315aae73461f9c21a0a8a9ac712e1caf8dd9993e34729227c7648bf6f72fad8488247986e560298f95aa2411bd4e395410565c0b527b9db4
DIST dash-0.5.11.3.tar.gz 244507 BLAKE2B 06d4bd9f4c93e76ddf895f5a0ebca0c18d9554f5d4fd30a948eafc862db0f4cd523f623dad75969ddb5f510ac85d174f3b3aac3726f9d3ca8fbdb4377715b244 SHA512 ffe69b8de3586aba298d936168c329524e385252e12979aa1db28761e882048eb5a80673e93a2a2227f61b52fd8b56546b78c5db9c21a022072f536267f8bc20
diff --git a/app-shells/dash/dash-0.5.11.2.ebuild b/app-shells/dash/dash-0.5.11.2.ebuild
deleted file mode 100644
index 0b87dea2b6c6..000000000000
--- a/app-shells/dash/dash-0.5.11.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Debian Almquist Shell"
-HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
-SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="libedit static"
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
-DEPEND="${RDEPEND}
- libedit? ( static? ( dev-libs/libedit[static-libs] ) )"
-
-src_prepare() {
- default
-
- # Fix the invalid sort
- sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
-
- # Use pkg-config for libedit linkage
- sed -i \
- -e "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" \
- configure || die
-}
-
-src_configure() {
- if [[ ${CHOST} == *-solaris* ]] ; then
- # don't redefine stat, open, dirent, etc. on Solaris
- export ac_cv_func_stat64=yes
- export ac_cv_func_open64=yes
-
- # if your headers strictly adhere to POSIX, you'll need this too
- [[ ${CHOST##*solaris2.} -le 10 ]] && append-cppflags -DNAME_MAX=255
- fi
- if [[ ${CHOST} == powerpc-*-darwin* ]] ; then
- sed -i -e 's/= stpncpy(s, \([^,]\+\), \([0-9]\+\))/+= snprintf(s, \2, "%s", \1)/' \
- src/jobs.c || die
- fi
- append-cppflags -DJOBS=$(usex libedit 1 0)
- use static && append-ldflags -static
- # Do not pass --enable-glob due to #443552.
- local myeconfargs=(
- CC_FOR_BUILD="$(tc-getBUILD_CC)"
- --bindir="${EPREFIX}"/bin
- --enable-fnmatch
- $(use_with libedit)
- )
- econf "${myeconfargs[@]}"
-}
diff --git a/app-shells/dash/dash-0.5.11.3.ebuild b/app-shells/dash/dash-0.5.11.3.ebuild
deleted file mode 100644
index 7f5b894786bc..000000000000
--- a/app-shells/dash/dash-0.5.11.3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Debian Almquist Shell"
-HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
-SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="libedit static"
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
-DEPEND="${RDEPEND}
- libedit? ( static? ( dev-libs/libedit[static-libs] ) )"
-
-src_prepare() {
- default
-
- # Fix the invalid sort
- sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
-
- # Use pkg-config for libedit linkage
- sed -i \
- -e "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" \
- configure || die
-}
-
-src_configure() {
- if [[ ${CHOST} == *-solaris* ]] ; then
- # don't redefine stat, open, dirent, etc. on Solaris
- export ac_cv_func_stat64=yes
- export ac_cv_func_open64=yes
-
- # if your headers strictly adhere to POSIX, you'll need this too
- [[ ${CHOST##*solaris2.} -le 10 ]] && append-cppflags -DNAME_MAX=255
- fi
- if [[ ${CHOST} == powerpc-*-darwin* ]] ; then
- sed -i -e 's/= stpncpy(s, \([^,]\+\), \([0-9]\+\))/+= snprintf(s, \2, "%s", \1)/' \
- src/jobs.c || die
- fi
- append-cppflags -DJOBS=$(usex libedit 1 0)
- use static && append-ldflags -static
- # Do not pass --enable-glob due to #443552.
- local myeconfargs=(
- CC_FOR_BUILD="$(tc-getBUILD_CC)"
- --bindir="${EPREFIX}"/bin
- --enable-fnmatch
- $(use_with libedit)
- )
- econf "${myeconfargs[@]}"
-}