summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-19 03:23:27 +0000
committerSam James <sam@gentoo.org>2022-11-19 03:23:27 +0000
commit60758ea023880e35f6dc7d45302814f0b7149315 (patch)
tree2b7026364af26afc0aa2a9f8372fc6a71829d2a7 /app-shells
parentsys-libs/minizip-ng: add 3.0.7 (diff)
downloadgentoo-60758ea023880e35f6dc7d45302814f0b7149315.tar.gz
gentoo-60758ea023880e35f6dc7d45302814f0b7149315.tar.bz2
gentoo-60758ea023880e35f6dc7d45302814f0b7149315.zip
app-shells/fzf: add 0.35.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.35.1.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index fffc74d52093..42bc8b7986da 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -2,3 +2,5 @@ DIST fzf-0.34.0-deps.tar.xz 16800704 BLAKE2B b518f7bff1ea533af32efcb0e5307580aa9
DIST fzf-0.34.0.tar.gz 214641 BLAKE2B ccb7f57df4305cf07dc8e0ba7384c3a446ddce083727ad98719a327150d853782bf781b0179d02f3f10664ffce501ebab55ccd2d5f61a2e690fa41f1d0f479c1 SHA512 6e2bd9a7c30862c09f627c73504f2a52951476abbd9af64941445862cc9bf783699cc9ccf215e25c49bbb3f9656841581b5805af4658b681b590ca14b5697331
DIST fzf-0.35.0-deps.tar.xz 16796112 BLAKE2B 61c22a914bb1eb8cb6da1daf4b25a19d98e7b0dcd1575b47b6da995ae0fb5e5bc47612b7abafe2917d12b4900a69e604ffff87bf31f811de449522fe800af8f4 SHA512 eed0a0c5a48c5dfee2b6c4d3320280d75f19c16841e3ad731371060da55885c3ddd8d0490dbfc53a68f095dcff02727e8d804494bfa8edf6da041ffcb197dc74
DIST fzf-0.35.0.tar.gz 218715 BLAKE2B 7eb4a36e481738e56e031ec6e10c69b6499bd6fde204f8bc9474f80b9c6371ca66ebafd5733d4b5de3f2a1fed0c7f2b9b8bbb97681d6194a79f6c82088d6c28e SHA512 8dfdee14b6eced0f2fffc717d6f4e33b93531002754cfcc6b915169feb5f0b62060addf26eb43af028d3d62cdda3c2581a878305ed2fd89f0b27622b6d813cbb
+DIST fzf-0.35.1-deps.tar.xz 16796112 BLAKE2B 61c22a914bb1eb8cb6da1daf4b25a19d98e7b0dcd1575b47b6da995ae0fb5e5bc47612b7abafe2917d12b4900a69e604ffff87bf31f811de449522fe800af8f4 SHA512 eed0a0c5a48c5dfee2b6c4d3320280d75f19c16841e3ad731371060da55885c3ddd8d0490dbfc53a68f095dcff02727e8d804494bfa8edf6da041ffcb197dc74
+DIST fzf-0.35.1.tar.gz 218773 BLAKE2B 79b95e23a85865ea9218a222eba522a0a9d7f042f9119b308bc711cccc5327098dae271ba10fff9619f3ba7bc88037c70459f1caf511d5069264b931c875c49f SHA512 4e32836aa331835b6a7370ea342d2ddfa47a2059f5f7c5eec0b2c0dc9fdede14940bf64977c91df201775b3f4a06763a92593df7a50693d04d13b1befb194753
diff --git a/app-shells/fzf/fzf-0.35.1.ebuild b/app-shells/fzf/fzf-0.35.1.ebuild
new file mode 100644
index 000000000000..2e451652dd32
--- /dev/null
+++ b/app-shells/fzf/fzf-0.35.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=b55f5554871e548c9c00a49df7a92f980c0191c2
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug 795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}