summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-11-09 16:18:34 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-11-09 18:20:44 +0100
commit6dc544b79527d19e0286b377ee34c8d1daf9fca3 (patch)
tree045cecbd6c01f1542127cf3ad1625893eee85c42 /app-shells
parentapp-arch/bzip3: bump to 1.2.1 (diff)
downloadgentoo-6dc544b79527d19e0286b377ee34c8d1daf9fca3.tar.gz
gentoo-6dc544b79527d19e0286b377ee34c8d1daf9fca3.tar.bz2
gentoo-6dc544b79527d19e0286b377ee34c8d1daf9fca3.zip
app-shells/pwsh-bin: bump to 7.3.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.3.0.ebuild51
2 files changed, 54 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index c7aa1875c539..05b7a1a79588 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -7,3 +7,6 @@ DIST powershell-7.2.6-linux-x64.tar.gz 69438809 BLAKE2B ae55f01e1fef540e0c0da317
DIST powershell-7.2.7-linux-arm32.tar.gz 66273712 BLAKE2B dcb949c0781660b51826817bce5d91842a28b9fac0b8b229763df24b83af10849d6a65d92a194b7b338779f32e8b71ab93bd97299ed2a26a006e547ade5e77f4 SHA512 b837b168d143c63aca193214d3513c43d54292560bf771b976b1909ba50fead34b5face5dda4d8e183d39761dac081b449d999f28980d62057179d4806771e85
DIST powershell-7.2.7-linux-arm64.tar.gz 64782906 BLAKE2B 35f7a31c4787ff6bca0a54d2a218383b1ac30b1fde35d20040313504d84f71f79e6d7c1f9429626e0c02e6ee62415e39ff0bf00b5348e6a546567c98c93c7c91 SHA512 5a8ec9d340ccaa31a6517b6b6b7bff4f08db39534cebcc59b23bf4ba885cab663618fe61723e50f2818d1c29f9d4692a49e2245559b19b6e1ec43c06924db294
DIST powershell-7.2.7-linux-x64.tar.gz 69431855 BLAKE2B 0a4fe34368abb5572cf86cc27b690df138a44c590c4364f7f7f79f8a4eaa27e126c6960f1959e7601304e1bda4c32af0785c4ea0b728967d014bf718abfdc672 SHA512 fcc48d5767f735c6348fdcf47eb3826f8b5d3efc48d97770796d0806ee6e2fe2989491bbd40ac1d3f2fbaf534a723ba3197037a54424c921958786f6b652e99e
+DIST powershell-7.3.0-linux-arm32.tar.gz 69194812 BLAKE2B e7862a69a75e78cca34738de3547102a7307550e36c562e48035695ee8e231489d0538f3da83faf0e4b9d76f369a061e3d7ddae7a85bf0833bd576902d800e78 SHA512 bdd5bac4d40c12877a3c721244974a2d56335437cb148e9ee3193e9df5969d709273897146f72ac0455567511bb21133f49fd85b733c0e26d9c15d6f9a8e1dc4
+DIST powershell-7.3.0-linux-arm64.tar.gz 68106561 BLAKE2B ff29f702e9fcf8d25cd44033851c120c8668aa083cbbdd2620526fac16ace2455d53456986813174d1da6a273cb6bf6936a7284cac614dbdf9af5252a56303c3 SHA512 7de1bd364289c3722f0956d83a9478ed9e7adfe572342b39afd838a0fce949ac9bc6420b1a8edcdbf390584ef5fee28caa55ea2d17d11b7da2cb7fbbf63ee792
+DIST powershell-7.3.0-linux-x64.tar.gz 71703612 BLAKE2B 0f741bded009758e0aa52104c9825b3f72f6806595dbc614b823a33f42b6727b4a5f5c785b93d79132252dc88dbc6a72b17e0cf64d3d17090346c773cbb844d4 SHA512 3610643fe842c2414a53277e3b3c102203ed9978f0f489175fea230a15e416a8f929e36e69a3d62cd242d8e01568c68906daf82816dff220bb1dc0aec164782c
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.3.0.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.3.0.ebuild
new file mode 100644
index 000000000000..43166039177b
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell - binary precompiled for glibc"
+HOMEPAGE="https://microsoft.com/powershell"
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+pwsh-symlink"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+ pwsh-symlink? ( !app-shells/pwsh )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local dest=opt/pwsh
+ dodir ${dest}
+
+ local broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ [[ -L ${symlink} ]] && { rm "${symlink}" || die ; }
+ done
+
+ mv "${S}/"* "${ED}"/${dest}/ || die
+ fperms 0755 /${dest}/pwsh
+
+ dosym ../../${dest}/pwsh /usr/bin/pwsh-bin
+ use pwsh-symlink && dosym ../../${dest}/pwsh /usr/bin/pwsh
+}