summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-12-26 01:09:21 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-26 01:29:35 +0100
commit7d814f26e156722a4541d56466dc3dfb5c0b6b2f (patch)
tree3db2235536a34eb4cebda0715774d2c9b2200839 /app-shells
parentapp-shells/scsh: EAPI 6 bump. (diff)
downloadgentoo-7d814f26e156722a4541d56466dc3dfb5c0b6b2f.tar.gz
gentoo-7d814f26e156722a4541d56466dc3dfb5c0b6b2f.tar.bz2
gentoo-7d814f26e156722a4541d56466dc3dfb5c0b6b2f.zip
app-shells/rrs: EAPI 6 bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/rrs/rrs-1.70-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/rrs/rrs-1.70-r2.ebuild b/app-shells/rrs/rrs-1.70-r2.ebuild
new file mode 100644
index 000000000000..99787758d34b
--- /dev/null
+++ b/app-shells/rrs/rrs-1.70-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Reverse Remote Shell"
+HOMEPAGE="http://freecode.com/projects/rrs"
+SRC_URI="http://www.cycom.se/uploads/36/19/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+PATCH=( "${FILESDIR}"/"${P}"-asneeded.patch)
+
+DOCS=( CHANGES README )
+
+src_prepare() {
+ default
+ sed -i -e "s#-s ##g" Makefile || die
+}
+
+src_compile() {
+ local target=""
+ use ssl || target="-nossl"
+
+ emake generic${target} CFLAGS="${CFLAGS}" LDEXTRA="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}