summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-26 13:51:06 +0100
committerSam James <sam@gentoo.org>2023-05-26 13:51:52 +0100
commit85b6d4c623b64e1603aced10418884b317b93e5b (patch)
tree7d80a8385149e1ecb493dd324de02150c5154da3 /app-shells
parentdev-python/tzlocal: Enable py3.12 (diff)
downloadgentoo-85b6d4c623b64e1603aced10418884b317b93e5b.tar.gz
gentoo-85b6d4c623b64e1603aced10418884b317b93e5b.tar.bz2
gentoo-85b6d4c623b64e1603aced10418884b317b93e5b.zip
app-shells/fzf: add 0.41.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.41.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index 7b7937b4c437..544f25c63a81 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -8,3 +8,5 @@ DIST fzf-0.39.0-deps.tar.xz 16890324 BLAKE2B ddf650dabbefcad339b677ae9196714c815
DIST fzf-0.39.0.tar.gz 235093 BLAKE2B 4db2877a6c7cc5418b643b572d17350f16794d6e417dd90da5684676ce04a341ce3a7fd3f2e7f6c5d740c9dabfc9c3faca2da2c5b9030e69403d847399f9db1b SHA512 0e8ccb460aeed5b5ccb04bba663b28565666c50a7c974fd0818ab6d6e4a7cd7958f285a47023f632a22417eee2130a670076180590c81f87d67081f39d566e5d
DIST fzf-0.40.0-deps.tar.xz 16914048 BLAKE2B c095faee297e2226d595f961bd1362c41e1b516eae225df4a25c28e9d0f4a4d65bbcb38db77d19d806cd3944dbbe42385566c3f7d59486fb3bafc3e0f2565073 SHA512 87b4ffa2f87c9d35cde56d6217beceadce94d72d7d8e5cf5a94c0873486ff954ea2e2d70e376a873d7f500af0e154b5e05af1ce745823ce96bd563697fd4ee01
DIST fzf-0.40.0.tar.gz 236930 BLAKE2B bbdf8d62c5b9f2e1a85c54e55e42d7a93366ff7f25104d1eb3b28dc49933c10bbe9a8bda68a80597f2734ed6888da744000db5b359a9523b40007f04ede06252 SHA512 03a9aae215b06cd2d0c318e7fb13c6e39012091e9773f00cba702323c5fe3b2b0161f48fe552188689be307e2d308c47afed53e1046a7a767bcd49c98c1dbf60
+DIST fzf-0.41.0-deps.tar.xz 16902176 BLAKE2B 96f888a2b00d8156b3423b9074915934b8034183be652cfe0f251cd93b5a44358360a55012c85b07325b193b51dcb266ecb1ec03f966385dfb2d474c7b2065a7 SHA512 0049d82220db6e9fd20d885b3706d6a13dd341d6d6953a7e403d035360612fc594dcc147a01d875302cffeacb977461f385d31ca3020a45cbcb7033f1b661020
+DIST fzf-0.41.0.tar.gz 238237 BLAKE2B eb716aaf60f3f9857ffb8f52fb54954ab73617f3004332c0ff3c06f63cdfc10af58ce5347e8e24badd2d43d1b6c91d4c2d79170b504c8b7912fc7c6d93721a28 SHA512 e37e61545d71b621b3a0f10609a7b2418b1fbf9da65a5101cdce442938e60fe3a61e20410321482917b5648e0aefe8c7538878eb39258128cac6500b769ecefb
diff --git a/app-shells/fzf/fzf-0.41.0.ebuild b/app-shells/fzf/fzf-0.41.0.ebuild
new file mode 100644
index 000000000000..1c9af3bbd3f2
--- /dev/null
+++ b/app-shells/fzf/fzf-0.41.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=098ef4d7cfb5465e15b29fc087f9db0b81733eec
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug #795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}