summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-10 15:01:30 +0100
committerSam James <sam@gentoo.org>2023-09-10 15:01:45 +0100
commit90c4b0adf2e3d14c510087ea393fccfbfc58562d (patch)
treeda546793ac5ac5a8d0dc6a98bf035b4cbd5780d9 /app-shells
parentmedia-libs/rubberband: Restrict GCC dependency to ppc (diff)
downloadgentoo-90c4b0adf2e3d14c510087ea393fccfbfc58562d.tar.gz
gentoo-90c4b0adf2e3d14c510087ea393fccfbfc58562d.tar.bz2
gentoo-90c4b0adf2e3d14c510087ea393fccfbfc58562d.zip
app-shells/fzf: keyword ~arm + Makefile fix for armv8l
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fzf/files/fzf-0.42.0-armv8l-bitness.patch24
-rw-r--r--app-shells/fzf/fzf-0.42.0-r1.ebuild (renamed from app-shells/fzf/fzf-0.42.0.ebuild)6
2 files changed, 29 insertions, 1 deletions
diff --git a/app-shells/fzf/files/fzf-0.42.0-armv8l-bitness.patch b/app-shells/fzf/files/fzf-0.42.0-armv8l-bitness.patch
new file mode 100644
index 000000000000..c8ec579f3ed4
--- /dev/null
+++ b/app-shells/fzf/files/fzf-0.42.0-armv8l-bitness.patch
@@ -0,0 +1,24 @@
+https://github.com/junegunn/fzf/pull/3434
+
+From 884d896893cb031e4532bd32403ced2020972806 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 10 Sep 2023 14:54:49 +0100
+Subject: [PATCH] Makefile: build 32-bit binary on armv8l
+
+armv8l is always 32-bit and should implement the armv7 ISA, so
+just use the same filename as for armv7.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/Makefile
++++ b/Makefile
+@@ -57,7 +57,9 @@ else ifeq ($(UNAME_M),armv6l)
+ else ifeq ($(UNAME_M),armv7l)
+ BINARY := $(BINARYARM7)
+ else ifeq ($(UNAME_M),armv8l)
+- BINARY := $(BINARYARM8)
++ # armv8l is always 32-bit and should implement the armv7 ISA, so
++ # just use the same filename as for armv7.
++ BINARY := $(BINARYARM7)
+ else ifeq ($(UNAME_M),arm64)
+ BINARY := $(BINARYARM8)
+ else ifeq ($(UNAME_M),aarch64)
diff --git a/app-shells/fzf/fzf-0.42.0.ebuild b/app-shells/fzf/fzf-0.42.0-r1.ebuild
index 098b99937497..4477d3f3bc71 100644
--- a/app-shells/fzf/fzf-0.42.0.ebuild
+++ b/app-shells/fzf/fzf-0.42.0-r1.ebuild
@@ -19,7 +19,11 @@ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar
LICENSE="MIT BSD-with-disclosure"
SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.42.0-armv8l-bitness.patch
+)
src_prepare() {
default