summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <floss@bsd.ac>2021-05-01 17:36:21 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-05-18 13:39:49 +0300
commita24ce47c615d8d293428525d2a4fd079a878a7b7 (patch)
tree6f76af9c67d77119e642bc61420f609b35301be7 /app-shells
parentnet-misc/unison: remove unused patch(es) (diff)
downloadgentoo-a24ce47c615d8d293428525d2a4fd079a878a7b7.tar.gz
gentoo-a24ce47c615d8d293428525d2a4fd079a878a7b7.tar.bz2
gentoo-a24ce47c615d8d293428525d2a4fd079a878a7b7.zip
app-shells/loksh: version bump to 6.9
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/20641 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/loksh/Manifest1
-rw-r--r--app-shells/loksh/loksh-6.9.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/loksh/Manifest b/app-shells/loksh/Manifest
index 9f9798239ae3..08b49cf1c9d4 100644
--- a/app-shells/loksh/Manifest
+++ b/app-shells/loksh/Manifest
@@ -1,2 +1,3 @@
DIST loksh-6.8.1.tar.xz 210424 BLAKE2B e02c51bbf3679c1c81ba66207576758f035bd2b666ceabdcdea6ec8cffb1dba7da2d4f4e812004ccfdb148f2615e239b3bee98e23f68a4e82b7bb364ca6b4e4e SHA512 e771e9bb91bf7ca11a41b5af71d6d62eec8205d111513461d20b7aeb029e9457868598508fbe7395c860f12a9dc8eff47f8ed913e5701ae5974777f7caffb861
DIST loksh-6.8.tar.xz 210440 BLAKE2B 438181e3fa5b95bc15d5cd2d5a42d09d595aefa45b8598532835f5df2464c40c6ebcab8febeee55f20272cbe3acc57f02d1408bf726cc9fc3435b7b35fae6e4a SHA512 bc862c4aa0796b0fde14c5c3067fc48c6325741bf7e62dcd99faa2ed0ddb80a8fcce79819ff599395f88ee8e5958ce4a451f777d0105fd8ea0ec513977d4e715
+DIST loksh-6.9.tar.xz 211408 BLAKE2B a8e1eb0e94b3f76246a4add7f66eae850d2e951994b2d79ce81423047696ab03221cdc7906e2ed46c4b8a8eec1b5b686cd828d9db36eb3d8e7a76f8f8046e12b SHA512 c4f74de049313adc9b0aae378435b9d3b259a6fd050f68b92b33551e3219840101c391f4cac3744deb8d121d9f6738ba66e76e029322303843bcc1b677bd3e9a
diff --git a/app-shells/loksh/loksh-6.9.ebuild b/app-shells/loksh/loksh-6.9.ebuild
new file mode 100644
index 000000000000..4d1334d7b864
--- /dev/null
+++ b/app-shells/loksh/loksh-6.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/loksh/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+
+RDEPEND="
+ ${DEPEND}
+ !app-shells/ksh
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ sed -i "/install_dir/s@loksh@${PF}@" meson.build || die
+}
+
+src_configure() {
+ # we want it as /bin/ksh
+ meson_src_configure --bindir=../bin
+}