summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-02 18:37:04 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-02 18:37:04 +0200
commitbf0753d42d7e135f0cf3de9594812ea1b9b8f745 (patch)
treebfffcad861f6a629a363b70b150fcf48122a7ba2 /app-shells
parentapp-shells/pwsh-bin: take up maintainership; update metadata (diff)
downloadgentoo-bf0753d42d7e135f0cf3de9594812ea1b9b8f745.tar.gz
gentoo-bf0753d42d7e135f0cf3de9594812ea1b9b8f745.tar.bz2
gentoo-bf0753d42d7e135f0cf3de9594812ea1b9b8f745.zip
app-shells/pwsh-bin: bump to EAPI 8; minor changes
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.2.1-r1.ebuild51
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.2.1.ebuild43
2 files changed, 51 insertions, 43 deletions
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.2.1-r1.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.2.1-r1.ebuild
new file mode 100644
index 000000000000..c78be49848d4
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.2.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell - binary precompiled for glibc"
+HOMEPAGE="https://powershell.org/"
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+pwsh-symlink"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+ pwsh-symlink? ( !app-shells/pwsh )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local dest=opt/pwsh
+ dodir ${dest}
+
+ local broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ [[ -L ${symlink} ]] && { rm "${symlink}" || die ; }
+ done
+
+ mv "${S}/"* "${ED}"/${dest}/ || die
+ fperms 0755 /${dest}/pwsh
+
+ dosym ../../${dest}/pwsh /usr/bin/pwsh-bin
+ use pwsh-symlink && dosym ../../${dest}/pwsh /usr/bin/pwsh
+}
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.2.1.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.2.1.ebuild
deleted file mode 100644
index b3bb0706496a..000000000000
--- a/app-shells/pwsh-bin/pwsh-bin-7.2.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-DESCRIPTION="PowerShell - binary precompiled for glibc"
-HOMEPAGE="https://powershell.org/"
-LICENSE="MIT"
-QA_PREBUILT="*"
-SRC_URI="
- amd64? ( https://github.com/PowerShell/PowerShell/releases/download/v${PV}/powershell-${PV}-linux-x64.tar.gz )
- arm? ( https://github.com/PowerShell/PowerShell/releases/download/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
- arm64? ( https://github.com/PowerShell/PowerShell/releases/download/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
-"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64"
-RDEPEND="
- app-crypt/mit-krb5:0/0
- dev-util/lttng-ust:0
- || ( dev-libs/openssl-compat:1.0.0 =dev-libs/openssl-1.0*:0/0 )
- sys-libs/pam:0/0
- sys-libs/zlib:0/1
- pwsh-symlink? ( !app-shells/pwsh )
-"
-IUSE="+pwsh-symlink"
-REQUIRED_USE="elibc_glibc"
-
-S=${WORKDIR}
-
-src_install() {
- local dest=opt/pwsh broken_symlinks=(libcrypto.so.1.0.0 libssl.so.1.0.0) symlink
- dodir "${dest}"
-
- for symlink in "${broken_symlinks[@]}"; do
- [[ -L ${symlink} ]] && { rm "${symlink}" || die; }
- done
-
- mv "${S}/"* "${ED}/${dest}/" || die
- fperms 0755 "/${dest}/pwsh"
-
- dosym "../../${dest}/pwsh" "/usr/bin/pwsh-bin"
- use pwsh-symlink && dosym "../../${dest}/pwsh" "/usr/bin/pwsh"
-}