summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-06-22 18:18:57 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-06-23 21:15:47 +0000
commitd12c6d14d31f4f86d08953f5795a7499825f7202 (patch)
tree765ca3f4de568c4011fb728dcd0374a004829b79 /app-shells
parentapp-editors/atom: Version bump to 1.8.0. (diff)
downloadgentoo-d12c6d14d31f4f86d08953f5795a7499825f7202.tar.gz
gentoo-d12c6d14d31f4f86d08953f5795a7499825f7202.tar.bz2
gentoo-d12c6d14d31f4f86d08953f5795a7499825f7202.zip
app-shells/mpv-bash-completion: verbump to 0.17
Remove redundant app-shells/bash blocker. This version also fixes Gentoo bug #586596. Gentoo-Bug: https://bugs.gentoo.org/586596 Package-Manager: portage-2.3.0_rc1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/mpv-bash-completion/Manifest1
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-0.17.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/mpv-bash-completion/Manifest b/app-shells/mpv-bash-completion/Manifest
index c7a14a3aaf4d..cfe14b11ba3d 100644
--- a/app-shells/mpv-bash-completion/Manifest
+++ b/app-shells/mpv-bash-completion/Manifest
@@ -1 +1,2 @@
DIST mpv-bash-completion-0.16.tar.gz 15023 SHA256 ceee842ad8498afc49c9a6ded424f2f301f681513a901d5efb6fd641ba163e10 SHA512 cdfc126a170026ac1c5654a43c6b155a648b090b4b0fed83494725c2d357d5c22dca3e43b2e6a8ea461db83c49880454d0bd8f7209b01d7c9bcdd232d532abd0 WHIRLPOOL 17b29f79435033fefb1800f28c6d1d37506d116cab49bdc06470a6ff792a4009e624a2150bdca2eeaa04756238e314e7277a9b34c6241e9845e8cdd76267df82
+DIST mpv-bash-completion-0.17.tar.gz 15033 SHA256 a4c3be027ec52fef684a545a43c05f32cf512da93ae4a569d273e6e182b90ab1 SHA512 851a9f2b5e54f176fc7519a5fceace2b3281bef4062a48e108f17b83ccbd53e7b7545969be9cbccd3f093ba9ee65bd6736650f1b4d88997808a8b1df40d769eb WHIRLPOOL ba077f686d2e9ba4e819cf30f17cdca5b98b321e6c39b72a3bd7c1f5269da3d20abe7f610838a51b941fdba8c6636fc3eaae81f07fcd08f8f61f6262d2d0fab5
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-0.17.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-0.17.ebuild
new file mode 100644
index 000000000000..d025b165614d
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-0.17.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="media-video/mpv[cli]"
+RDEPEND="${DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+
+DOCS=( KNOWN_BUGS README.mkd )
+
+src_compile() {
+ "${S}"/gen.sh > ${PN} || die
+}
+
+src_install() {
+ einstalldocs
+ newbashcomp ${PN} mpv
+}