summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2017-08-21 13:25:57 -0700
committerDaniel Campbell <zlg@gentoo.org>2017-08-21 13:27:00 -0700
commitd37508ec22d73c7c40bf95692a2d39be0ea2fe4e (patch)
tree3485611c6afbb43fc0519176b63514a768bab319 /app-shells
parentpackage.mask: Last rite xfce-extra/xfce4-mixer, #628424 (diff)
downloadgentoo-d37508ec22d73c7c40bf95692a2d39be0ea2fe4e.tar.gz
gentoo-d37508ec22d73c7c40bf95692a2d39be0ea2fe4e.tar.bz2
gentoo-d37508ec22d73c7c40bf95692a2d39be0ea2fe4e.zip
app-shells/tmux-bash-completion: new package
Gentoo-Bug: 604688 Gentoo-Bug-URL: https://bugs.gentoo.org/604688 Thanks, Gleb. Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/tmux-bash-completion/metadata.xml15
-rw-r--r--app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild25
2 files changed, 40 insertions, 0 deletions
diff --git a/app-shells/tmux-bash-completion/metadata.xml b/app-shells/tmux-bash-completion/metadata.xml
new file mode 100644
index 000000000000..1f6ba86c16f2
--- /dev/null
+++ b/app-shells/tmux-bash-completion/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>imomaliev@github.com</email>
+ <name>Sardorbek Imomaliev</name>
+ </maintainer>
+ <remote-id type="github">imomaliev/tmux-bash-completion</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild b/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild
new file mode 100644
index 000000000000..da4498863deb
--- /dev/null
+++ b/app-shells/tmux-bash-completion/tmux-bash-completion-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="bash-completion scripts for tmux"
+HOMEPAGE="https://github.com/imomaliev/tmux-bash-completion"
+EGIT_REPO_URI="https://github.com/imomaliev/tmux-bash-completion.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ >=app-misc/tmux-2.2
+ app-shells/bash-completion
+ "
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ dobashcomp "${S}"/completions/tmux
+}