summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-12-30 19:13:23 -0500
committerTim Harder <radhermit@gentoo.org>2016-12-30 19:13:23 -0500
commitdfe4f93556986be962ddac5d6af5f62e1b9fd62d (patch)
tree6ac1afc509e3541052289b54805890f96508c63b /app-shells
parentdev-libs/libnl: Old. (diff)
downloadgentoo-dfe4f93556986be962ddac5d6af5f62e1b9fd62d.tar.gz
gentoo-dfe4f93556986be962ddac5d6af5f62e1b9fd62d.tar.bz2
gentoo-dfe4f93556986be962ddac5d6af5f62e1b9fd62d.zip
app-shells/zsh: version bump to 5.3.1
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/Manifest2
-rw-r--r--app-shells/zsh/zsh-5.3.1.ebuild218
2 files changed, 220 insertions, 0 deletions
diff --git a/app-shells/zsh/Manifest b/app-shells/zsh/Manifest
index f97838d9c1dc..f5f22ca42b3e 100644
--- a/app-shells/zsh/Manifest
+++ b/app-shells/zsh/Manifest
@@ -3,4 +3,6 @@ DIST zsh-5.0.5.tar.bz2 3104375 SHA256 6624d2fb6c8fa4e044d2b009f86ed1617fe8583c83
DIST zsh-5.2-doc.tar.xz 3108600 SHA256 328352cf3d5d0ec4b6e31dcefd25ff5b4c0e6b8077d1fe84448ebb50d6ada52a SHA512 a2e6b95c293546011e1697e0a2f66a3740092ef61904fa3b469f33e8af0ced6028fac77cd51ebe9ee4cb168403d9af7c72fd071a15ba3dc273243bd71fa714a0 WHIRLPOOL a6b023af9e3d94d31b56aba688c2bf3c16ff6ed1dc9db34dd970c4bf0461e24b7aab0b9113cc5f16bd87ab2ca9d973a990a3721c08500cbcd45fa2fe2d43a260
DIST zsh-5.2.tar.xz 2820108 SHA256 f17916320ffaa844bbd7ce48ceeb5945fc5f3eff64b149b4229bbfbdf3795a9d SHA512 9938af95e09203a0a313f441e0c23279136806f6f087475ca9a66c678c57ecffc87f73ece8133a36700af8de7cb5d1bec8559eabdec2b66102062e64026c2e72 WHIRLPOOL 5348ce11026a4e50d0ecf118cb379e9765cb98fcf32563489fd860ad0234c3f3aefb7f3fe28d18a97f2ddba54dc2b2cf9909b81cdc0e213f26f599ba68fd8833
DIST zsh-5.3-doc.tar.xz 3161944 SHA256 cdfc6c3f7235b13308af5316cfa87abb5f51b3ec72d45f9043fde6e5b2e8663e SHA512 29d5731d48170e7bc96337e9ae10f58a9f6fcd7698b4dcaacf17b9e490c8084cb781fc3d9a06ddcaddb9d3957b86d9040cc8e7b13d4b5649e2be181508a95ef4 WHIRLPOOL caf5ef406d7bc616ddd1eeecfd5ed95fa560a49d914059a225569cae63be8c92bd01a88fce4314fb6272218f189c09196bcb3c5a72f737257c7d0263251ad2f1
+DIST zsh-5.3.1-doc.tar.xz 3161408 SHA256 d51762fcb5699c332da8a4e404cb9eb8d5de8fa4e0235a08bcf252c915bda6ed SHA512 27f9d50094c21a77b36fe3309a9ab81a2ccf6570139b11038bbebe9fff2d0701f0bccf9163f5bf47d51ce7b978df621a4cb9089c33e9179a61636fcc94a9fb9c WHIRLPOOL 40d10cf9767a168f2619b0bed947d6a05a45bece6a5a5bd353422fef88ca267bf2f03f18f6ce9ee86def9219b13e3c8fa145f73c22bb3f9d786ee6eddd773953
+DIST zsh-5.3.1.tar.xz 2928832 SHA256 fc886cb2ade032d006da8322c09a7e92b2309177811428b121192d44832920da SHA512 25f723c76d2779c3cb53de2e0dbb1163ec289f76282bec49757880d0ce32bf64a001a6b40c54c290d342aa09f92319af5c597bff99de8dbd1fc895c11836f304 WHIRLPOOL cdd62b5c144a7b416bb46b7a14ddc12f5e1ff133acc292abcdc94d402b2c0a6b57667f962cb808bdd52fdedd4b98fb5669327d1754183f242f29bdaea73747fc
DIST zsh-5.3.tar.xz 2928684 SHA256 76f82cfd5ce373cf799a03b6f395283f128430db49202e3e3f512fb5a19d6f8a SHA512 b34da1a062954ccb166b0a22fa48b0d08bdb8f50fd96cb391f04887c0bf416e771ceaa8af8fa7da2dc2e6f7c3ecce5c92c4e3bee21fd93e467849c8febc021b0 WHIRLPOOL 9d52e36528c2272e2de33144bd76ddb50e505ecc2dec13e332c9e9185be1e919b5f4276de052b0d558d5f809c0437d1a85491924a6febd143dcfced53c323c81
diff --git a/app-shells/zsh/zsh-5.3.1.ebuild b/app-shells/zsh/zsh-5.3.1.ebuild
new file mode 100644
index 000000000000..292321453f4e
--- /dev/null
+++ b/app-shells/zsh/zsh-5.3.1.ebuild
@@ -0,0 +1,218 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic prefix
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SRC_URI="http://www.zsh.org/pub/${P}.tar.xz
+ doc? ( http://www.zsh.org/pub/${P}-doc.tar.xz )"
+fi
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+
+LICENSE="ZSH gdbm? ( GPL-2 )"
+SLOT="0"
+IUSE="caps debug doc examples gdbm maildir pcre static unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1:0=
+ static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
+ caps? ( sys-libs/libcap )
+ pcre? (
+ >=dev-libs/libpcre-3.9
+ static? ( >=dev-libs/libpcre-3.9[static-libs] )
+ )
+ gdbm? ( sys-libs/gdbm )
+"
+DEPEND="sys-apps/groff
+ ${RDEPEND}"
+PDEPEND="
+ examples? ( app-doc/zsh-lovers )
+"
+if [[ ${PV} == 9999* ]] ; then
+ DEPEND+=" app-text/yodl
+ doc? (
+ sys-apps/texinfo
+ app-text/texi2html
+ virtual/latex-base
+ )"
+fi
+
+src_prepare() {
+ if [[ ${PV} != 9999* ]]; then
+ # fix zshall problem with soelim
+ ln -s Doc man1 || die
+ mv Doc/zshall.1 Doc/zshall.1.soelim || die
+ soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
+
+ # add openrc specific options for init.d completion
+ eapply "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
+ fi
+
+ cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
+ eprefixify "${T}"/zprofile || die
+ if use prefix ; then
+ sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
+ else
+ sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
+ fi
+
+ eapply_user
+
+ if [[ ${PV} == 9999* ]] ; then
+ sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconf=()
+
+ if use static ; then
+ myconf+=( --disable-dynamic )
+ append-ldflags -static
+ fi
+ if use debug ; then
+ myconf+=(
+ --enable-zsh-debug
+ --enable-zsh-mem-debug
+ --enable-zsh-mem-warning
+ --enable-zsh-secure-free
+ --enable-zsh-hash-debug
+ )
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ myconf+=( --enable-libs=-liconv )
+ append-ldflags -Wl,-x
+ fi
+
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --enable-etcdir="${EPREFIX}"/etc/zsh \
+ --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help \
+ --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions \
+ --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
+ --enable-function-subdirs \
+ --with-tcsetpgrp \
+ $(use_enable maildir maildir-support) \
+ $(use_enable pcre) \
+ $(use_enable caps cap) \
+ $(use_enable unicode multibyte) \
+ $(use_enable gdbm ) \
+ "${myconf[@]}"
+
+ if use static ; then
+ # compile all modules statically, see Bug #27392
+ # removed cap and curses because linking failes
+ sed -e "s,link=no,link=static,g" \
+ -e "/^name=zsh\/cap/s,link=static,link=no," \
+ -e "/^name=zsh\/curses/s,link=static,link=no," \
+ -i "${S}"/config.modules || die
+ if ! use gdbm ; then
+ sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
+ "${S}"/config.modules || die
+ fi
+ fi
+}
+
+src_compile() {
+ default
+
+ if [[ ${PV} == 9999* ]] && use doc ; then
+ emake -C Doc everything
+ fi
+}
+
+src_test() {
+ addpredict /dev/ptmx
+ local i
+ for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
+ rm "${S}"/Test/${i} || die
+ done
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install $(usex doc "install.info" "")
+
+ insinto /etc/zsh
+ doins "${T}"/zprofile
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/${PV%_*}/functions/Prompts
+ newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
+
+ local i
+
+ # install miscellaneous scripts (bug #54520)
+ sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
+ -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
+ -i {Util,Misc}/* || die
+ for i in Util Misc ; do
+ insinto /usr/share/zsh/${PV%_*}/${i}
+ doins ${i}/*
+ done
+
+ # install header files (bug #538684)
+ insinto /usr/include/zsh
+ doins config.h Src/*.epro
+ for i in Src/{zsh.mdh,*.h} ; do
+ sed -e 's@\.\./config\.h@config.h@' \
+ -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
+ -i "${i}"
+ doins "${i}"
+ done
+
+ dodoc ChangeLog* META-FAQ NEWS README config.modules
+
+ if use doc ; then
+ pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
+ docinto html
+ dodoc Doc/*.html
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf}
+ popd >/dev/null
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ echo
+ elog "If you want to enable Portage completions and Gentoo prompt,"
+ elog "emerge app-shells/gentoo-zsh-completions and add"
+ elog " autoload -U compinit promptinit"
+ elog " compinit"
+ elog " promptinit; prompt gentoo"
+ elog "to your ~/.zshrc"
+ echo
+ elog "Also, if you want to enable cache for the completions, add"
+ elog " zstyle ':completion::complete:*' use-cache 1"
+ elog "to your ~/.zshrc"
+ echo
+ elog "Note that a system zprofile startup file is installed. This will override"
+ elog "PATH and possibly other variables that a user may set in ~/.zshenv."
+ elog "Custom PATH settings and similar overridden variables can be moved to ~/.zprofile"
+ elog "or other user startup files that are sourced after the system zprofile."
+ echo
+ elog "If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,"
+ elog "one method is to use a separate path-setting file that is conditionally sourced"
+ elog "in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the"
+ elog "zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/."
+ echo
+ elog "See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation."
+ echo
+ fi
+}