summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-07-26 18:47:43 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-07-31 11:02:48 +0200
commite6a47460d88dda5e9f7a113a904def19841e9e99 (patch)
tree19232286c278131b373b3ff341a5f3559962183a /app-shells
parentmedia-libs/gst-plugins-base: Enable opus support (#589440 by holgersson) (diff)
downloadgentoo-e6a47460d88dda5e9f7a113a904def19841e9e99.tar.gz
gentoo-e6a47460d88dda5e9f7a113a904def19841e9e99.tar.bz2
gentoo-e6a47460d88dda5e9f7a113a904def19841e9e99.zip
app-shells/mpv-bash-completion: verbump to 3.3.4
Package-Manager: portage-2.3.0 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/mpv-bash-completion/Manifest1
-rw-r--r--app-shells/mpv-bash-completion/mpv-bash-completion-3.3.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-shells/mpv-bash-completion/Manifest b/app-shells/mpv-bash-completion/Manifest
index de3995c78f44..e4b59235a9be 100644
--- a/app-shells/mpv-bash-completion/Manifest
+++ b/app-shells/mpv-bash-completion/Manifest
@@ -1,2 +1,3 @@
DIST mpv-bash-completion-0.17.tar.gz 15033 SHA256 a4c3be027ec52fef684a545a43c05f32cf512da93ae4a569d273e6e182b90ab1 SHA512 851a9f2b5e54f176fc7519a5fceace2b3281bef4062a48e108f17b83ccbd53e7b7545969be9cbccd3f093ba9ee65bd6736650f1b4d88997808a8b1df40d769eb WHIRLPOOL ba077f686d2e9ba4e819cf30f17cdca5b98b321e6c39b72a3bd7c1f5269da3d20abe7f610838a51b941fdba8c6636fc3eaae81f07fcd08f8f61f6262d2d0fab5
DIST mpv-bash-completion-3.3.3.tar.gz 18314 SHA256 8f4d538b618bd89f3b55e7831863679f7583fd1175afc3cabd2b614a9e3b7f88 SHA512 97bb8926685abc62f8147da55c816aa47304819c87c4be0b47701bb5b5dede1eb4a008efa75a0894cbb14b5b92aace300169809d2fc37c1f1708dc3a99e6e278 WHIRLPOOL fe8ea9732e3a638e92790a9d705f0ad003ca9ab8e8a23dae302aaa1147c55c90178e8a99be8ab6e56e3f07b64fa118d3e2392cdc0878bafd63c637cd0df6efff
+DIST mpv-bash-completion-3.3.4.tar.gz 18400 SHA256 393bee900e505fd40efe4e4f266b5a60de6480daf52c195033e630a5f0fb42e1 SHA512 044adaf554d1de7c9ac984c6aa4b9339fdb9f909ab64d5020f86d1e431918fa83b139fa787e4fcc8575937a824a94ce9d6abb3f69f03d540e54d9f389b4f646b WHIRLPOOL 274986f6beb9ac5f1db6fc7737277052f0057a4d7c70b00a6c42f0f419a9005db5e73d953f2e048f2abd201090bc6b3e2f247efbc3e2fd339bd1b7bab4cb7269
diff --git a/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.4.ebuild b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.4.ebuild
new file mode 100644
index 000000000000..fc46881998b7
--- /dev/null
+++ b/app-shells/mpv-bash-completion/mpv-bash-completion-3.3.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Bash completion for the mpv video player"
+HOMEPAGE="https://2ion.github.io/mpv-bash-completion/"
+SRC_URI="https://github.com/2ion/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="luajit"
+
+COMMON_DEPEND="media-video/mpv[cli]"
+RDEPEND="${COMMON_DEPEND}
+ >=app-shells/bash-completion-2.3-r1
+"
+DEPEND="${COMMON_DEPEND}
+ !luajit? ( dev-lang/lua:* )
+ luajit? ( dev-lang/luajit:2 )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Avoid 'mpv' make target that supports lua only.
+ sed -i -e 's|check: mpv|check:|' Makefile || die
+}
+
+src_compile() {
+ $(usex luajit 'luajit' 'lua') gen.lua > mpv || die
+}
+
+src_install() {
+ dobashcomp mpv
+ einstalldocs
+}
+
+pkg_postinst() {
+ if ! has_version 'x11-apps/xrandr'; then
+ echo
+ elog "If you want completion of window sizes, please install 'x11-apps/xrandr'."
+ echo
+ fi
+}