summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-10-02 19:10:51 +0200
committerFabian Groffen <grobian@gentoo.org>2022-10-02 19:10:51 +0200
commite765140dd27ed066aa1eb16bb457df0e40425a2a (patch)
tree3c86548706d060e36a22f72856880906a37a9de7 /app-shells
parentdev-ruby/pundit: enable ruby31 and disable ruby26 (diff)
downloadgentoo-e765140dd27ed066aa1eb16bb457df0e40425a2a.tar.gz
gentoo-e765140dd27ed066aa1eb16bb457df0e40425a2a.tar.bz2
gentoo-e765140dd27ed066aa1eb16bb457df0e40425a2a.zip
app-shells/tcsh-6.24.01-r1: bump config for egrep fixes
Closes: https://bugs.gentoo.org/873097 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/tcsh/Manifest1
-rw-r--r--app-shells/tcsh/tcsh-6.24.01-r1.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/app-shells/tcsh/Manifest b/app-shells/tcsh/Manifest
index eb3d3a22c667..75d045b23778 100644
--- a/app-shells/tcsh/Manifest
+++ b/app-shells/tcsh/Manifest
@@ -1,3 +1,4 @@
DIST tcsh-6.24.00.tar.gz 949411 BLAKE2B 0751707e233fedc2b8a9360f27e8f4a3e030956e97809b0a52ffe0541b6d15b4f7ff2cbd0832743f702757129366a979ecab745342823d9bbb1863c1d024646d SHA512 0a50332aadd4309a8b1506a4771ac77c5368c4e1952dd719bd01eca15711743983ff13ec7098dbaf565b4293ac0355ff565344991e0d0c0c9ef75237220e7730
DIST tcsh-6.24.01.tar.gz 949438 BLAKE2B 4f3005e98d02aa12cea41405ab7e56cd840ba207d36a657699041b045f537bfbf1c992a20435ee97ea21b4bb25f0d7af532ccd2ef50de8542ca94f914e3f3ca5 SHA512 47425f9bc5ae3df163fe1c9f8a1b1a6c3893b186843d561fb7020c75561587286036cc679212f17fd0f760735d9e01da414e60a69db0ffcb74276f053ea80479
+DIST tcsh-gentoo-patches-r1.10.tar.xz 2344 BLAKE2B 82131a926b99734173c2524cddfad69cdfc4653370699da8ebc135bd198a32b0bb290ff93b7a478dcf02c7353a82a2cc4efb0a2e39539d1a74ea9fea1b3f7e2a SHA512 d9e01c9b162529501b5eaafe031dfe880818129f4d197a07012e698293841269568a19c595453259d784129271c7f7230b6ce326880b06c4c82bb89b8645a3f4
DIST tcsh-gentoo-patches-r1.9.tar.bz2 2488 BLAKE2B 58924e623c75068cdc686be61755bdbcf8d0949a2141ac532ac089f80ff083b2c9f6767038b9fc52171a00ed82c558b83216327c87b41f51c3648343869cd5b6 SHA512 9903e9c3e2279abcac09a3235f3c5db9f42156c18137eb651ede195ca2b069f0b5bc6105fed33666b69796c4ebf03e4efe63cd9beba1898bac7297a2f74bfd3d
diff --git a/app-shells/tcsh/tcsh-6.24.01-r1.ebuild b/app-shells/tcsh/tcsh-6.24.01-r1.ebuild
new file mode 100644
index 000000000000..99b20ee7fa02
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.24.01-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic autotools prefix
+
+CONFVER="1.10"
+
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="https://www.tcsh.org/"
+SRC_URI="
+ ftp://ftp.astron.com/pub/tcsh/${P}.tar.gz
+ ftp://ftp.astron.com/pub/tcsh/old/${P}.tar.gz
+ https://dev.gentoo.org/~grobian/distfiles/tcsh-gentoo-patches-r${CONFVER}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls doc"
+RESTRICT="test"
+
+# we need gettext because we run autoconf (AM_ICONV)
+RDEPEND="
+ >=sys-libs/ncurses-5.1:0=
+ virtual/libcrypt:=
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-lang/perl )"
+
+CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.23.02-dircolors.patch # bug #120792
+ "${FILESDIR}"/${PN}-6.21.04-no-nls.patch
+ "${FILESDIR}"/${PN}-6.21.00-use-ncurses.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ # fix gencat usage
+ sed \
+ -e 's/cat \$\^ \$> | \$(GENCAT) \$@/rm -f $@; $(GENCAT) $@ $> $^/' \
+ -i nls/Makefile.in || die
+
+ # always use sysmalloc, the builtin malloc fails on Darwin, musl,
+ # etc. it's already used for glibc-linux, so this doesn't change
+ # anything for the majority of users
+ sed -i -e 's/undef SYSMALLOC/define SYSMALLOC/' config_f.h || die
+
+ # unify ECHO behaviour
+ echo "#undef ECHO_STYLE" >> config_f.h
+ echo "#define ECHO_STYLE BOTH_ECHO" >> config_f.h
+
+ eprefixify "${CONFDIR}"/*
+ # activate the right default PATH
+ if [[ -z ${EPREFIX} ]] ; then
+ sed -i \
+ -e 's/^#MAIN//' -e '/^#PREFIX/d' \
+ "${CONFDIR}"/csh.login || die
+ else
+ sed -i \
+ -e 's/^#PREFIX//' -e '/^#MAIN/d' \
+ "${CONFDIR}"/csh.login || die
+ fi
+
+ eapply_user
+}
+
+src_configure() {
+ # make tcsh look and live along the lines of the prefix
+ append-cppflags -D_PATH_DOTCSHRC="'"'"${EPREFIX}/etc/csh.cshrc"'"'"
+ append-cppflags -D_PATH_DOTLOGIN="'"'"${EPREFIX}/etc/csh.login"'"'"
+ append-cppflags -D_PATH_DOTLOGOUT="'"'"${EPREFIX}/etc/csh.logout"'"'"
+ append-cppflags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
+ append-cppflags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
+
+ # musl's utmp is non-functional
+ if use elibc_musl ; then
+ export ac_cv_header_utmp_h=no
+ export ac_cv_header_utmpx_h=no
+ fi
+
+ econf \
+ --prefix="${EPREFIX:-}" \
+ --datarootdir='${prefix}/usr/share' \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man
+
+ DOCS=( FAQ Fixes NewThings Ported README.md WishList Y2K )
+ if use doc ; then
+ perl tcsh.man2html tcsh.man || die
+ HTML_DOCS=( tcsh.html/*.html )
+ fi
+ einstalldocs
+
+ insinto /etc
+ doins \
+ "${CONFDIR}"/csh.cshrc \
+ "${CONFDIR}"/csh.login
+
+ # bug #119703: add csh -> tcsh symlink
+ dosym tcsh /bin/csh
+}