summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-01 09:55:03 +0000
committerSam James <sam@gentoo.org>2021-06-01 10:08:03 +0000
commite8d3dcfa4e14512b9f28aacf2a39732dbf3b3a10 (patch)
tree051278ef0424faf36fae70f9e7b9fc15b8424098 /app-shells
parent*/*: update email on my packages (diff)
downloadgentoo-e8d3dcfa4e14512b9f28aacf2a39732dbf3b3a10.tar.gz
gentoo-e8d3dcfa4e14512b9f28aacf2a39732dbf3b3a10.tar.bz2
gentoo-e8d3dcfa4e14512b9f28aacf2a39732dbf3b3a10.zip
app-shells/powerline: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/powerline/powerline-2.7-r2.ebuild9
-rw-r--r--app-shells/powerline/powerline-9999.ebuild11
2 files changed, 7 insertions, 13 deletions
diff --git a/app-shells/powerline/powerline-2.7-r2.ebuild b/app-shells/powerline/powerline-2.7-r2.ebuild
index 8ece4fd915b5..af11ad885111 100644
--- a/app-shells/powerline/powerline-2.7-r2.ebuild
+++ b/app-shells/powerline/powerline-2.7-r2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
-DESCRIPTION="The ultimate statusline/prompt utility."
+DESCRIPTION="The ultimate statusline/prompt utility"
HOMEPAGE="https://github.com/powerline/powerline"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -23,9 +23,6 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
PATCHES=(
"${FILESDIR}"/2.7-ldflags.patch
)
diff --git a/app-shells/powerline/powerline-9999.ebuild b/app-shells/powerline/powerline-9999.ebuild
index bee72318c1b8..a0c3ea937dde 100644
--- a/app-shells/powerline/powerline-9999.ebuild
+++ b/app-shells/powerline/powerline-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
-DESCRIPTION="The ultimate statusline/prompt utility."
+DESCRIPTION="The ultimate statusline/prompt utility"
HOMEPAGE="https://github.com/powerline/powerline"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -15,14 +15,11 @@ if [[ ${PV} == 9999 ]]; then
S="${WORKDIR}/powerline-${PV}"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}-status/${PN}-status-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}-status-${PV}"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""