summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBailey Kasin <baileykasin@gmail.com>2023-09-13 06:16:55 -0700
committerFlorian Schmaus <flow@gentoo.org>2023-09-14 09:44:46 +0200
commitfba6341540f1069da84dee95ad9bb5d315228052 (patch)
tree31c7cd8bad9ab91553b9455e33f6de15f6f41e3f /app-shells
parentsys-kernel/vanilla-kernel: Remove old (diff)
downloadgentoo-fba6341540f1069da84dee95ad9bb5d315228052.tar.gz
gentoo-fba6341540f1069da84dee95ad9bb5d315228052.tar.bz2
gentoo-fba6341540f1069da84dee95ad9bb5d315228052.zip
app-shells/gentoo-zsh-completions: add 20230117
Signed-off-by: Bailey Kasin <baileykasin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32761 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/gentoo-zsh-completions/Manifest1
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20230117.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-shells/gentoo-zsh-completions/Manifest b/app-shells/gentoo-zsh-completions/Manifest
index d7f0b3297e9e..da938c573254 100644
--- a/app-shells/gentoo-zsh-completions/Manifest
+++ b/app-shells/gentoo-zsh-completions/Manifest
@@ -1 +1,2 @@
DIST gentoo-zsh-completions-20220112.tar.gz 25839 BLAKE2B 3cf9a26e14556520ff32172b0e97ee5cb5e3cf45569c97b6f3e701330490be831f211dde327fdd007df9b67df22c243f4e91e0f40b9d4d02551b0b3059d60708 SHA512 b06aa69348b0954b8cf635170fa743960e5d4c3988c0dfa6166e1d4d33bf112e24d1e28bd5a0b228a0d6e78509a8e62954217bbd30c099d99cad4ebab71b328d
+DIST gentoo-zsh-completions-20230117.tar.gz 25805 BLAKE2B 33b1db3c9e4ab2b4c86a9b378618cda399835ae71fcda320ac6f0123cd2e25683bff260c644dcc27408c831183d5273e4afa15987ff90196380a608c4558bf8b SHA512 00a4f015967fabc2192e4e07f5d7c46ee0d8cd43aebb0dd7876f6d97aeac7d099c5470c100dad531f373502c4094f3689622a083dfe5610111ccf80970334e07
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20230117.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20230117.ebuild
new file mode 100644
index 000000000000..5b710a44d1e4
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20230117.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/gentoo/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}