summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/active-dvi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/active-dvi')
-rw-r--r--app-text/active-dvi/Manifest1
-rw-r--r--app-text/active-dvi/active-dvi-1.10.2-r1.ebuild73
-rw-r--r--app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch13
-rw-r--r--app-text/active-dvi/metadata.xml5
4 files changed, 92 insertions, 0 deletions
diff --git a/app-text/active-dvi/Manifest b/app-text/active-dvi/Manifest
new file mode 100644
index 000000000000..3f849e1a4533
--- /dev/null
+++ b/app-text/active-dvi/Manifest
@@ -0,0 +1 @@
+DIST advi-1.10.2.tar.gz 9772060 SHA256 01556d20896db57c1d05961b2dd48a44d2fbca2adb10d4a9ded732bcf6cb0cc6 SHA512 93479e22261019b571bc331604a659e4e58200284bcdd63929b2c7ab07f8e9fabbd120f8876081a36e7e09e08286eeba9a45f3b077b545a9e404060622ec45c8 WHIRLPOOL 007d4e59c615deeeef0979dff8aca6aa1e088b1542de9076cd2a7f4c4e593a68110249f660c17e50ff25ef20eba5067d1640713fd7c9f44ead19e269c5a8bb47
diff --git a/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild b/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild
new file mode 100644
index 000000000000..95988ec20122
--- /dev/null
+++ b/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools texlive-common
+
+MY_PN=${PN/ctive-/}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A DVI previewer and a presenter for slides written in LaTeX"
+SRC_URI="http://gallium.inria.fr/advi/${MY_P}.tar.gz"
+HOMEPAGE="http://gallium.inria.fr/advi/"
+LICENSE="LGPL-2.1"
+
+IUSE="+ocamlopt"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+RDEPEND=">=dev-lang/ocaml-3.11.2:=[ocamlopt?]
+ >=dev-ml/camlimages-4.0.1:=[truetype,tiff,jpeg,postscript,X]
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ dev-texlive/texlive-pstricks
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-latexextra
+ x11-proto/xineramaproto
+ dev-ml/findlib
+ app-text/htmlc
+ dev-tex/hevea"
+
+DOCS=( "README" "TODO" )
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.9-htmlcflags.patch"
+ AT_M4DIR="." eautoreconf
+}
+
+src_configure() {
+ TEXMFMAIN="${EPREFIX}"/usr/share/texmf-site econf $(use_enable ocamlopt native-program) \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" --enable-dependency-tracking #486066
+}
+
+src_compile() {
+ emake
+ cd doc || die
+ VARTEXFONTS="${T}/fonts" emake splash.dvi scratch_write_splash.dvi scratch_draw_splash.dvi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PACKAGE="${PF}" install
+
+ # now install the documentation
+ dodoc ${DOCS}
+
+ export STRIP_MASK="*/bin/advi.byt"
+
+ for i in "${ED}/usr/share/doc/${PF}/"*.dvi ; do
+ docompress -x /usr/share/doc/${PF}/$(basename $i)
+ done
+}
+
+pkg_postinst() {
+ etexmf-update
+}
+
+pkg_postrm() {
+ etexmf-update
+}
diff --git a/app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch b/app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch
new file mode 100644
index 000000000000..59697ec4dc83
--- /dev/null
+++ b/app-text/active-dvi/files/active-dvi-1.9-htmlcflags.patch
@@ -0,0 +1,13 @@
+Index: advi-1.9/doc/Makefile.am
+===================================================================
+--- advi-1.9.orig/doc/Makefile.am
++++ advi-1.9/doc/Makefile.am
+@@ -113,6 +113,8 @@ TEX_ENV = TEXINPUTS=$(srcdir):$(top_src
+ HEVEA_FLAGS = -entities -I $(srcdir) -I $(top_srcdir)/tex
+ HTMLC_FLAGS = -I $(srcdir)/includes \
+ -D CamlVersion '$(OCAMLVERSION)' \
++ -D HOSTNAME "$(HOSTNAME)" \
++ -D USER "$(USER)" \
+ -D version '$(VERSION)'
+
+ MV = mv -f
diff --git a/app-text/active-dvi/metadata.xml b/app-text/active-dvi/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-text/active-dvi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>