summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-20 23:55:03 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-20 23:55:03 +0100
commitfad01b3e00e58a85752af1987627f2e841cca7d3 (patch)
tree4b7b01ce1f2a9e03a997ffd33cdf67d94743e5dd /app-text/agrep/agrep-2.04-r2.ebuild
parentdev-java/icedtea-bin: Add ppc64 binaries to 3.3.0 (diff)
downloadgentoo-fad01b3e00e58a85752af1987627f2e841cca7d3.tar.gz
gentoo-fad01b3e00e58a85752af1987627f2e841cca7d3.tar.bz2
gentoo-fad01b3e00e58a85752af1987627f2e841cca7d3.zip
app-text/agrep: EAPI 6 bump.
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-text/agrep/agrep-2.04-r2.ebuild')
-rw-r--r--app-text/agrep/agrep-2.04-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/agrep/agrep-2.04-r2.ebuild b/app-text/agrep/agrep-2.04-r2.ebuild
new file mode 100644
index 000000000000..3b3fa268ac5c
--- /dev/null
+++ b/app-text/agrep/agrep-2.04-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool for the fast searching of text allowing for errors in the search pattern"
+HOMEPAGE="ftp://ftp.cs.arizona.edu/agrep/README"
+SRC_URI="ftp://ftp.cs.arizona.edu/${PN}/${P}.tar.Z"
+
+LICENSE="AGREP"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~sparc-solaris"
+
+RDEPEND="
+ !dev-libs/tre
+ !app-misc/glimpse"
+
+DOCS=( README agrep.algorithms agrep.chronicle COPYRIGHT contribution.list )
+
+src_compile() {
+ sed -i -e 's/^CFLAGS.*//' \
+ -e "s:\$(CFLAGS):& \$(LDFLAGS) :" Makefile || die
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}