summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-06-10 12:05:48 +0200
committerJeroen Roovers <jer@gentoo.org>2017-06-10 12:06:06 +0200
commit1146cbe9b5041f9d42966dbc70828a7fd044b649 (patch)
tree503779ab6532be9c957fb750c856946eb65fd06f /app-text/an/an-1.2-r1.ebuild
parentdev-python/pypy3: Fix typo in --jit-backend, #621384 (diff)
downloadgentoo-1146cbe9b5041f9d42966dbc70828a7fd044b649.tar.gz
gentoo-1146cbe9b5041f9d42966dbc70828a7fd044b649.tar.bz2
gentoo-1146cbe9b5041f9d42966dbc70828a7fd044b649.zip
app-text/an: EAPI bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-text/an/an-1.2-r1.ebuild')
-rw-r--r--app-text/an/an-1.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/an/an-1.2-r1.ebuild b/app-text/an/an-1.2-r1.ebuild
new file mode 100644
index 000000000000..d9c01423a53c
--- /dev/null
+++ b/app-text/an/an-1.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Very fast anagram generator with dictionary lookup"
+HOMEPAGE="http://packages.debian.org/unstable/games/an"
+
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/icu:=
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/miscfiles[-minimal]
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CC/s|:=|?=|' \
+ -e 's|$(CC) $(CFLAGS)|& $(LDFLAGS)|g' \
+ -e '/^CPPFLAGS/s|-D_BSD_SOURCE=1 -D_GNU_SOURCE=1|-D_DEFAULT_SOURCE=1|g' \
+ Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.6 ${PN}.1
+ dodoc ALGORITHM
+}