summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/apvlv/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/apvlv/files')
-rw-r--r--app-text/apvlv/files/apvlv-0.1.4-cmake.patch32
-rw-r--r--app-text/apvlv/files/apvlv-0.1.5-cflags.patch20
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/apvlv/files/apvlv-0.1.4-cmake.patch b/app-text/apvlv/files/apvlv-0.1.4-cmake.patch
new file mode 100644
index 000000000000..43c11596b8b0
--- /dev/null
+++ b/app-text/apvlv/files/apvlv-0.1.4-cmake.patch
@@ -0,0 +1,32 @@
+diff -ruN apvlv-0.1.4-Source/src/CMakeLists.txt my/src/CMakeLists.txt
+--- apvlv-0.1.4-Source/src/CMakeLists.txt 2012-06-13 05:44:28.000000000 +0200
++++ my/src/CMakeLists.txt 2012-07-17 00:32:53.782141814 +0200
+@@ -1,23 +1,18 @@
+ IF (WIN32)
+ ADD_DEFINITIONS (-D_CRT_SECURE_NO_WARNINGS)
+ ELSE (WIN32)
+- SET (CMAKE_CXX_FLAGS "-Wall -fno-strict-aliasing")
+-
+- OPTION (APVLV_ENABLE_DEBUG "If build binary with debug infomations." OFF)
+- IF (APVLV_ENABLE_DEBUG)
+- SET (CMAKE_CXX_FLAGS "-D_DEBUG -g ${CMAKE_CXX_FLAGS}")
+- ELSE (APVLV_ENABLE_DEBUG)
+- SET (CMAKE_CXX_FLAGS "-O2 ${CMAKE_CXX_FLAGS}")
+- ENDIF (APVLV_ENABLE_DEBUG)
++ SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -fno-strict-aliasing")
+ ENDIF (WIN32)
+
+ FIND_PACKAGE (PkgConfig)
+
+-PKG_CHECK_MODULES (FREETYPE2 freetype2 REQUIRED)
+ PKG_CHECK_MODULES (GTK2 gtk+-2.0 REQUIRED)
+ PKG_CHECK_MODULES (GLIB2 glib-2.0 REQUIRED)
+ PKG_CHECK_MODULES (GTHREAD2 gthread-2.0 REQUIRED)
+-PKG_CHECK_MODULES (WEBKIT1 webkit-1.0 QUIET)
++
++IF (APVLV_WITH_HTML)
++ PKG_CHECK_MODULES (WEBKIT1 webkit-1.0 REQUIRED)
++ENDIF (APVLV_WITH_HTML)
+ INCLUDE_DIRECTORIES (${FREETYPE2_INCLUDE_DIRS}
+ ${GTK2_INCLUDE_DIRS}
+ ${GLIB2_INCLUDE_DIRS}
diff --git a/app-text/apvlv/files/apvlv-0.1.5-cflags.patch b/app-text/apvlv/files/apvlv-0.1.5-cflags.patch
new file mode 100644
index 000000000000..d1859fa25701
--- /dev/null
+++ b/app-text/apvlv/files/apvlv-0.1.5-cflags.patch
@@ -0,0 +1,20 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index ae9ae09..5831e7a 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1,13 +1,11 @@
+ IF (WIN32)
+ ADD_DEFINITIONS (-D_CRT_SECURE_NO_WARNINGS)
+ ELSE (WIN32)
+- SET (CMAKE_CXX_FLAGS "-Wall -fno-strict-aliasing")
++ SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -fno-strict-aliasing")
+
+ OPTION (APVLV_ENABLE_DEBUG "If build binary with debug infomations." OFF)
+ IF (APVLV_ENABLE_DEBUG)
+- SET (CMAKE_CXX_FLAGS "-D_DEBUG -g ${CMAKE_CXX_FLAGS}")
+- ELSE (APVLV_ENABLE_DEBUG)
+- SET (CMAKE_CXX_FLAGS "-O2 ${CMAKE_CXX_FLAGS}")
++ SET (CMAKE_CXX_FLAGS "-D_DEBUG ${CMAKE_CXX_FLAGS}")
+ ENDIF (APVLV_ENABLE_DEBUG)
+ ENDIF (WIN32)
+