summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/asciidoc/asciidoc-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/asciidoc/asciidoc-9999.ebuild')
-rw-r--r--app-text/asciidoc/asciidoc-9999.ebuild107
1 files changed, 107 insertions, 0 deletions
diff --git a/app-text/asciidoc/asciidoc-9999.ebuild b/app-text/asciidoc/asciidoc-9999.ebuild
new file mode 100644
index 000000000000..038e1f95e6d0
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-9999.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+[ "$PV" == "9999" ] && inherit mercurial autotools
+inherit python-single-r1
+
+DESCRIPTION="A text document format for writing short documents, articles, books and UNIX man pages"
+HOMEPAGE="http://www.methods.co.nz/asciidoc/"
+if [ "$PV" == "9999" ]; then
+ EHG_REPO_URI="https://asciidoc.googlecode.com/hg/"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples graphviz highlight test vim-syntax"
+
+REQUIRED_USE="highlight? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ graphviz? ( media-gfx/graphviz )
+ app-text/docbook-xml-dtd:4.5
+ highlight? ( || ( dev-python/pygments[${PYTHON_USEDEP}] dev-util/source-highlight ) )
+ ${PYTHON_DEPS}
+"
+DEPEND="test? ( dev-util/source-highlight
+ media-sound/lilypond
+ media-gfx/imagemagick
+ dev-texlive/texlive-latex
+ app-text/dvipng
+ media-gfx/graphviz
+ ${PYTHON_DEPS} )
+"
+
+if [ "$PV" == "9999" ]; then
+ DEPEND="${DEPEND}
+ dev-util/aap
+ www-client/lynx
+ dev-util/source-highlight"
+fi
+
+src_prepare() {
+ if ! use vim-syntax; then
+ sed -i -e '/^install/s/install-vim//' Makefile.in || die
+ else
+ sed -i\
+ -e "/^vimdir/s:@sysconfdir@/vim:${EPREFIX}/usr/share/vim/vimfiles:" \
+ -e 's:/etc/vim::' \
+ Makefile.in || die
+ fi
+
+ # Only needed for prefix - harmless (does nothing) otherwise
+ sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
+ "${S}/asciidoc.py" || die
+
+ [ "$PV" == "9999" ] && eautoconf
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/usr/share
+}
+
+src_compile() {
+ default
+
+ if [ "$PV" == "9999" ]; then
+ cd doc || die
+ aap -f main.aap ../{CHANGELOG,README,BUGS} || die
+ fi
+}
+
+src_install() {
+ use vim-syntax && dodir /usr/share/vim/vimfiles
+
+ emake DESTDIR="${D}" install
+
+ python_fix_shebang "${ED}"/usr/bin/*.py
+
+ if use examples; then
+ # This is a symlink to a directory
+ rm examples/website/images || die
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ dosym ../../../asciidoc/images /usr/share/doc/${PF}/examples
+ fi
+
+ dodoc BUGS CHANGELOG README docbook-xsl/asciidoc-docbook-xsl.txt \
+ dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt
+}
+
+src_test() {
+ cd tests || die
+ local -x ASCIIDOC_PY=../asciidoc.py
+ "${PYTHON}" test${PN}.py update || die
+ "${PYTHON}" test${PN}.py run || die
+}