summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Joliet <marcec@gmx.de>2015-11-16 12:12:21 +0100
committerMarc Joliet <marcec@gmx.de>2015-11-16 12:53:01 +0100
commit7672a28aa4458c0dd1481bbcdc60642040acb337 (patch)
treef0a21b0ce6908224db6ff118c351c98d29b15a1b /app-text/asciidoc
parentUpdate gnome 3.18 mask (diff)
downloadgentoo-7672a28aa4458c0dd1481bbcdc60642040acb337.tar.gz
gentoo-7672a28aa4458c0dd1481bbcdc60642040acb337.tar.bz2
gentoo-7672a28aa4458c0dd1481bbcdc60642040acb337.zip
app-text/asciidoc: use readme.gentoo for some deps
Use readme.gentoo to refer to the a2x(1) man page for a list of runtime dependencies instead of forcing the app-text/dblatex and lynx/w3m dependencies. Since this commit removes the direct dependency on app-text/dblatex, it also restores previously dropped KEYWORDS to ~arch. Gentoo-bug: 565844 Signed-off-by: Marc Joliet <marcec@gmx.de>
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/asciidoc-8.6.9-r2.ebuild12
-rw-r--r--app-text/asciidoc/asciidoc-9999.ebuild12
2 files changed, 16 insertions, 8 deletions
diff --git a/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild b/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild
index c4347b381002..e329c8e742d5 100644
--- a/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild
+++ b/app-text/asciidoc/asciidoc-8.6.9-r2.ebuild
@@ -6,12 +6,12 @@ EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
-inherit python-single-r1
+inherit readme.gentoo python-single-r1
DESCRIPTION="AsciiDoc is a plain text human readable/writable document format"
HOMEPAGE="http://asciidoc.org/"
SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
LICENSE="GPL-2"
SLOT="0"
@@ -23,8 +23,6 @@ RDEPEND=">=app-text/docbook-xsl-stylesheets-1.75
dev-libs/libxslt
graphviz? ( media-gfx/graphviz )
app-text/docbook-xml-dtd:4.5
- app-text/dblatex
- || ( www-client/w3m www-client/lynx )
highlight? ( || ( dev-util/source-highlight \
dev-python/pygments[${PYTHON_USEDEP}] \
app-text/highlight )
@@ -40,6 +38,11 @@ DEPEND="test? ( dev-util/source-highlight
${PYTHON_DEPS} )
"
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
src_prepare() {
if ! use vim-syntax; then
sed -i -e '/^install/s/install-vim//' Makefile.in || die
@@ -66,6 +69,7 @@ src_install() {
python_fix_shebang "${ED}"/usr/bin/*.py
+ readme.gentoo_create_doc
dodoc BUGS CHANGELOG README docbook-xsl/asciidoc-docbook-xsl.txt \
dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt
diff --git a/app-text/asciidoc/asciidoc-9999.ebuild b/app-text/asciidoc/asciidoc-9999.ebuild
index 3e19725242a1..0a4f1a949fe4 100644
--- a/app-text/asciidoc/asciidoc-9999.ebuild
+++ b/app-text/asciidoc/asciidoc-9999.ebuild
@@ -7,7 +7,7 @@ EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
[ "$PV" == "9999" ] && inherit mercurial autotools
-inherit python-single-r1
+inherit readme.gentoo python-single-r1
DESCRIPTION="AsciiDoc is a plain text human readable/writable document format"
HOMEPAGE="http://www.methods.co.nz/asciidoc/"
@@ -17,7 +17,7 @@ if [ "$PV" == "9999" ]; then
KEYWORDS=""
else
SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -30,8 +30,6 @@ RDEPEND=">=app-text/docbook-xsl-stylesheets-1.75
dev-libs/libxslt
graphviz? ( media-gfx/graphviz )
app-text/docbook-xml-dtd:4.5
- app-text/dblatex
- || ( www-client/w3m www-client/lynx )
highlight? ( || ( dev-util/source-highlight \
dev-python/pygments[${PYTHON_USEDEP}] \
app-text/highlight )
@@ -47,6 +45,11 @@ DEPEND="test? ( dev-util/source-highlight
${PYTHON_DEPS} )
"
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
if [ "$PV" == "9999" ]; then
DEPEND="${DEPEND}
dev-util/aap
@@ -100,6 +103,7 @@ src_install() {
dosym ../../../asciidoc/images /usr/share/doc/${PF}/examples
fi
+ readme.gentoo.create_doc
dodoc BUGS CHANGELOG README docbook-xsl/asciidoc-docbook-xsl.txt \
dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt
}