summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kołodziej <kacper@kolodziej.in>2016-09-25 16:05:22 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-28 23:02:06 +0200
commit03eaa0cf8c05dc6b3398c08aef0101dcebb6e72a (patch)
tree8b31796e7a5685ad2870ecc1e7186e42a9b9dfae /app-text/bact/bact-0.13.ebuild
parentsci-electronics/freehdl: Version bump to 0.0.8 (diff)
downloadgentoo-03eaa0cf8c05dc6b3398c08aef0101dcebb6e72a.tar.gz
gentoo-03eaa0cf8c05dc6b3398c08aef0101dcebb6e72a.tar.bz2
gentoo-03eaa0cf8c05dc6b3398c08aef0101dcebb6e72a.zip
app-text/bact: fix cpp14 compilation errors; bug #594312
Closes: https://github.com/gentoo/gentoo/pull/2409 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/bact/bact-0.13.ebuild')
-rw-r--r--app-text/bact/bact-0.13.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-text/bact/bact-0.13.ebuild b/app-text/bact/bact-0.13.ebuild
index 98d29fb5500b..00cd99778b7c 100644
--- a/app-text/bact/bact-0.13.ebuild
+++ b/app-text/bact/bact-0.13.ebuild
@@ -4,7 +4,7 @@
EAPI=4
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="Boosting Algorithm for Classification of Trees"
HOMEPAGE="http://chasen.org/~taku/software/bact/"
@@ -18,6 +18,10 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-cpp14.patch" # bug #594312
+}
+
src_compile() {
emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
}