summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/barcode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/barcode')
-rw-r--r--app-text/barcode/Manifest1
-rw-r--r--app-text/barcode/barcode-0.98-r1.ebuild37
-rw-r--r--app-text/barcode/files/0.98-info.patch14
-rw-r--r--app-text/barcode/metadata.xml8
4 files changed, 60 insertions, 0 deletions
diff --git a/app-text/barcode/Manifest b/app-text/barcode/Manifest
new file mode 100644
index 000000000000..bf8f04590f43
--- /dev/null
+++ b/app-text/barcode/Manifest
@@ -0,0 +1 @@
+DIST barcode-0.98.tar.gz 335658 SHA256 4229e19279b9787ac7e98852fa0bfd93986dce93b9cb07d93a017d68d409b635 SHA512 b2ff43d0c752a9fe7c17d65ef136ff2432ceddd27879c91cb18e46e9b0fc8ed6c174aa4154c0fa6d6e70c478ac86448b8eafa1857bb759159b2eaecc8d6f7ca1 WHIRLPOOL 30bdb0037b5c69e6638175c27f96cce3329934b4febb634c48bd1b3b49cf2b6ef20462bb93432e4b3965f6f9f6a2f3d33d80a3dfa9365d9b69c993403a159327
diff --git a/app-text/barcode/barcode-0.98-r1.ebuild b/app-text/barcode/barcode-0.98-r1.ebuild
new file mode 100644
index 000000000000..4da85c5fcdfe
--- /dev/null
+++ b/app-text/barcode/barcode-0.98-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="barcode generator"
+HOMEPAGE="http://www.gnu.org/software/barcode/"
+SRC_URI="mirror://gnu/barcode/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+RDEPEND="app-text/libpaper"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-info.patch
+ sed -i -e '/^LDFLAGS =/s:=:+=:' \
+ -e "/^aLIBDIR/s:lib:$(get_libdir):" \
+ -e '/^INFODIR/s:info:share/info:' \
+ -e '/^MAN/s:man:share/man:' \
+ Makefile.in || die
+}
+
+src_configure() {
+ tc-export CC
+ econf
+}
+
+src_install() {
+ emake install prefix="${ED}/usr"
+ dodoc ChangeLog README TODO doc/barcode.{pdf,ps}
+}
diff --git a/app-text/barcode/files/0.98-info.patch b/app-text/barcode/files/0.98-info.patch
new file mode 100644
index 000000000000..740458f88ed4
--- /dev/null
+++ b/app-text/barcode/files/0.98-info.patch
@@ -0,0 +1,14 @@
+--- doc/barcode.info.old 2003-10-26 19:08:39.000000000 -0800
++++ doc/barcode.info 2003-10-26 19:58:42.179447512 -0800
+@@ -1,6 +1,11 @@
+ This is barcode.info, produced by makeinfo version 4.0 from
+ barcode.texinfo.
+
++INFO-DIR-SECTION Miscellaneous
++START-INFO-DIR-ENTRY
++* Barcode: (barcode). Barcode generation library.
++END-INFO-DIR-ENTRY
++
+ This file is the User's Manual for the barcode library (version
+ 0.98).
+
diff --git a/app-text/barcode/metadata.xml b/app-text/barcode/metadata.xml
new file mode 100644
index 000000000000..01598fe69ee3
--- /dev/null
+++ b/app-text/barcode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+</maintainer>
+</pkgmetadata>