summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-12 12:50:43 +0000
committerSam James <sam@gentoo.org>2021-01-12 12:51:07 +0000
commitf344ba337727c9a2cacd0ac7b66002749e1451d2 (patch)
tree5959450fe2c228189e39f9d5a3de5ef0e0dd1c63 /app-text/bibclean/bibclean-3.04.ebuild
parentapp-text/teckit: bump to 2.5.10 (diff)
downloadgentoo-f344ba337727c9a2cacd0ac7b66002749e1451d2.tar.gz
gentoo-f344ba337727c9a2cacd0ac7b66002749e1451d2.tar.bz2
gentoo-f344ba337727c9a2cacd0ac7b66002749e1451d2.zip
app-text/bibclean: bump to 3.04
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/bibclean/bibclean-3.04.ebuild')
-rw-r--r--app-text/bibclean/bibclean-3.04.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/bibclean/bibclean-3.04.ebuild b/app-text/bibclean/bibclean-3.04.ebuild
new file mode 100644
index 000000000000..d7f1a69fa5e6
--- /dev/null
+++ b/app-text/bibclean/bibclean-3.04.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="BibTeX bibliography prettyprinter and syntax checker"
+SRC_URI="ftp://ftp.math.utah.edu/pub/bibclean/${P}.tar.gz"
+HOMEPAGE="http://www.math.utah.edu/pub/bibclean/"
+
+# http://packages.debian.org/changelogs/pool/main/b/bibclean/bibclean_2.11.4-5/bibclean.copyright
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+SLOT="0"
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin bibclean
+ newman bibclean.man bibclean.1
+}