summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 21:40:34 +0100
committerSam James <sam@gentoo.org>2021-04-19 21:54:05 +0100
commit5394e99bedc11545e2afe5a8d829df2304763a0c (patch)
tree71841540225129af21719ca2a5d07f2bb66ead28 /app-text/blahtexml/blahtexml-0.9.ebuild
parentapp-laptop/tpb: port to EAPI 7 (diff)
downloadgentoo-5394e99bedc11545e2afe5a8d829df2304763a0c.tar.gz
gentoo-5394e99bedc11545e2afe5a8d829df2304763a0c.tar.bz2
gentoo-5394e99bedc11545e2afe5a8d829df2304763a0c.zip
app-text/blahtexml: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/blahtexml/blahtexml-0.9.ebuild')
-rw-r--r--app-text/blahtexml/blahtexml-0.9.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/app-text/blahtexml/blahtexml-0.9.ebuild b/app-text/blahtexml/blahtexml-0.9.ebuild
index 5e893a55f267..f470b6197643 100644
--- a/app-text/blahtexml/blahtexml-0.9.ebuild
+++ b/app-text/blahtexml/blahtexml-0.9.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="TeX-to-MathML converter"
HOMEPAGE="http://gva.noekeon.org/blahtexml"
@@ -15,16 +15,24 @@ KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 x86"
IUSE="doc"
RDEPEND="dev-libs/xerces-c"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
doc? (
app-text/texlive-core
dev-libs/libxslt
- dev-tex/latex2html )"
+ dev-tex/latex2html
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-{Makefile,gcc-4.7}.patch
+)
src_prepare() {
- tc-export CC CXX
- epatch "${FILESDIR}"/${P}-{Makefile,gcc-4.7}.patch
+ default
+
+ tc-export CC CXX PKG_CONFIG
}
src_compile() {