summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-02 03:22:23 +0100
committerSam James <sam@gentoo.org>2023-04-02 03:55:36 +0100
commit06caa1e439d441f0d95b898717a35626e54b6b94 (patch)
tree1702a7de7a737adaa248eeb51c06a1549b292856 /app-text/blahtexml
parentapp-text/blahtexml: add github upstream metadata (diff)
downloadgentoo-06caa1e439d441f0d95b898717a35626e54b6b94.tar.gz
gentoo-06caa1e439d441f0d95b898717a35626e54b6b94.tar.bz2
gentoo-06caa1e439d441f0d95b898717a35626e54b6b94.zip
app-text/blahtexml: add 1.0
Closes: https://bugs.gentoo.org/832214 Closes: https://bugs.gentoo.org/838991 Closes: https://bugs.gentoo.org/880359 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/blahtexml')
-rw-r--r--app-text/blahtexml/Manifest1
-rw-r--r--app-text/blahtexml/blahtexml-1.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/blahtexml/Manifest b/app-text/blahtexml/Manifest
index 93987c7798a2..dc20ec31bba8 100644
--- a/app-text/blahtexml/Manifest
+++ b/app-text/blahtexml/Manifest
@@ -1 +1,2 @@
DIST blahtexml-0.9-src.tar.gz 168564 BLAKE2B 941f241adf6e423cd0eff4a13b11313d6cad143badb6d862be01bd603f84aa04f224ae2d84abfef05341c66e410ba18bf39d99f636a8a33512e1da9739770a19 SHA512 5a5ddd50c0b3a25954135c44de0ac3a3d992e3e9dd691a552512415c385a39011595683877cdf98aee77d6ef2f9dae750214798ec2af69b8de089d0aec64b042
+DIST blahtexml-1.0.tar.gz 191236 BLAKE2B 1daf42be183cb28eaf14bbca92055f715a9d0da829bb6515d132315c5f3f4866484398d8dfcf87eaf7997b03e21b86aa331fb532ecfd2bdc6e10751ccaba8699 SHA512 919c7cbeeacec25af166678bc74da2be480d082edbc8fc534f416a1cbb3495c5e9788591666a94527a07dcddfb8b27d321a0fa442c84bbcbd444bb46a559da84
diff --git a/app-text/blahtexml/blahtexml-1.0.ebuild b/app-text/blahtexml/blahtexml-1.0.ebuild
new file mode 100644
index 000000000000..6e6ac194f3ce
--- /dev/null
+++ b/app-text/blahtexml/blahtexml-1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="TeX-to-MathML converter"
+HOMEPAGE="http://gva.noekeon.org/blahtexml"
+SRC_URI="https://github.com/gvanas/blahtexml/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD CC-BY-3.0 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/xerces-c"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-text/texlive-core
+ dev-texlive/texlive-latexextra
+ dev-libs/libxslt
+ dev-tex/latex2html
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9-Makefile.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export CC CXX PKG_CONFIG
+}
+
+src_compile() {
+ emake blahtex{,ml}-linux
+ use doc && emake doc
+}
+
+src_install() {
+ dobin blahtex ${PN}
+ doman "${FILESDIR}"/${PN}.1
+ use doc && dodoc Documentation/manual.pdf
+}