summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/cb2bib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/cb2bib')
-rw-r--r--app-text/cb2bib/Manifest2
-rw-r--r--app-text/cb2bib/cb2bib-1.4.9.ebuild48
-rw-r--r--app-text/cb2bib/cb2bib-1.5.0.ebuild54
-rw-r--r--app-text/cb2bib/metadata.xml8
4 files changed, 112 insertions, 0 deletions
diff --git a/app-text/cb2bib/Manifest b/app-text/cb2bib/Manifest
new file mode 100644
index 000000000000..08532ce5fd9c
--- /dev/null
+++ b/app-text/cb2bib/Manifest
@@ -0,0 +1,2 @@
+DIST cb2bib-1.4.9.tar.gz 853588 SHA256 a12e3f05df5f05e180bc1ff3af8cfcb2fc6142cd2ab7d452706e86a449e1b359 SHA512 95e990772ccb0d789f18dc8b54fc37e432a91e76a7cd6355aa0ddafca5f9cc4d468fc433a50f4006d3eaed35136e9535ae09123a7fd55fbb989fb64234a96308 WHIRLPOOL 65b6b80a689f45a78863450c27e20ec9e5f33a33d32e9fbf7ece370465b77983fcb05c690b962843c9232f5dc6c9bd4dc3fbc7a487573e13348b9b9b15b58de9
+DIST cb2bib-1.5.0.tar.gz 899936 SHA256 e5eae392c9223889fb21c5a656b014d5a81a333c5378196075a985233885f3b9 SHA512 bc1149ebc1dc2f6fb0e2bf04dedc156c2decd5f76a3b57bc24713db5827afb83e5ff2ef4b380d6a4fa6f80ce6375bfa97b2cfdc6d7540f620e3f541a586e998b WHIRLPOOL b4de5b4ad924ae623403070d95d50cbfa378676ed76519d7ec9002c686dd26da6ea8a43531f8c0147c0206a157ca44e9e94c50d53564a78e7a0a098ccb293f53
diff --git a/app-text/cb2bib/cb2bib-1.4.9.ebuild b/app-text/cb2bib/cb2bib-1.4.9.ebuild
new file mode 100644
index 000000000000..f51f07a6cd8a
--- /dev/null
+++ b/app-text/cb2bib/cb2bib-1.4.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Tool for extracting unformatted bibliographic references"
+HOMEPAGE="http://www.molspaces.com/cb2bib/"
+SRC_URI="http://www.molspaces.com/dl/progs/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="amd64 x86"
+IUSE="debug +lzo +webkit"
+
+DEPEND="
+ x11-libs/libX11
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ lzo? ( dev-libs/lzo:2 )
+ webkit? ( dev-qt/qtwebkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DC2B_USE_LZO=$(use lzo && echo ON || echo OFF)
+ -DC2B_USE_WEBKIT=$(use webkit && echo ON || echo OFF)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ elog "For best functionality, emerge the following packages:"
+ elog " app-text/poppler[utils] - for data import from PDF files"
+ elog " app-text/dvipdfm - for data import from DVI files"
+ elog " app-text/bibutils - for data import from ISI, endnote format"
+ elog " media-fonts/jsmath - for displaying mathematical notation"
+ elog " media-libs/exiftool - for proper UTF-8 metadata writing in PDF"
+ elog " text strings"
+ elog " virtual/latex-base - to check for BibTeX file correctness and to get"
+ elog " nice printing through the shell script bib2pdf"
+ einfo
+}
diff --git a/app-text/cb2bib/cb2bib-1.5.0.ebuild b/app-text/cb2bib/cb2bib-1.5.0.ebuild
new file mode 100644
index 000000000000..aae6b935a3b8
--- /dev/null
+++ b/app-text/cb2bib/cb2bib-1.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Tool for extracting unformatted bibliographic references"
+HOMEPAGE="http://www.molspaces.com/cb2bib/"
+SRC_URI="http://www.molspaces.com/dl/progs/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +lzo +webkit"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-libs/libX11
+ lzo? ( dev-libs/lzo:2 )
+ webkit? ( dev-qt/qtwebkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Fix desktop files
+ sed -i -e '/Keywords=/ s/$/;/' c2bscripts/{c2bciter,cb2bib}.desktop || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DC2B_USE_LZO=$(use lzo && echo ON || echo OFF)
+ -DC2B_USE_WEBKIT=$(use webkit && echo ON || echo OFF)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ elog "For best functionality, emerge the following packages:"
+ elog " app-text/poppler[utils] - for data import from PDF files"
+ elog " app-text/dvipdfm - for data import from DVI files"
+ elog " app-text/bibutils - for data import from ISI, endnote format"
+ elog " media-fonts/jsmath - for displaying mathematical notation"
+ elog " media-libs/exiftool - for proper UTF-8 metadata writing in PDF"
+ elog " text strings"
+ elog " virtual/latex-base - to check for BibTeX file correctness and to get"
+ elog " nice printing through the shell script bib2pdf"
+ einfo
+}
diff --git a/app-text/cb2bib/metadata.xml b/app-text/cb2bib/metadata.xml
new file mode 100644
index 000000000000..0452c21ae39c
--- /dev/null
+++ b/app-text/cb2bib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <bugs-to>webmaster@molspaces.com</bugs-to>
+ </upstream>
+</pkgmetadata>