summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-01-15 05:35:14 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2018-01-15 05:36:35 -0500
commit3bd0d4f1dc2390b9543236942409b98c51cbd7de (patch)
tree8fd4e973e64fa18ea85d82701d7f8d7deff3e9c0 /app-text/cedilla/cedilla-0.7.ebuild
parentapp-office/gnucash: Bump to 2.7.3 (diff)
downloadgentoo-3bd0d4f1dc2390b9543236942409b98c51cbd7de.tar.gz
gentoo-3bd0d4f1dc2390b9543236942409b98c51cbd7de.tar.bz2
gentoo-3bd0d4f1dc2390b9543236942409b98c51cbd7de.zip
app-text/cedilla: Bump to 0.7
Closes: https://bugs.gentoo.org/451880 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-text/cedilla/cedilla-0.7.ebuild')
-rw-r--r--app-text/cedilla/cedilla-0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/cedilla/cedilla-0.7.ebuild b/app-text/cedilla/cedilla-0.7.ebuild
new file mode 100644
index 000000000000..d6e687479ec5
--- /dev/null
+++ b/app-text/cedilla/cedilla-0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="UTF-8 to postscript converter"
+HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/cedilla/"
+SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="dev-lisp/clisp"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/cedilla-gentoo-r1.patch )
+
+src_compile() {
+ ./compile-cedilla || die "Compile failed."
+}
+
+src_install() {
+ sed "s#${ED%/}##g" -i cedilla || die "sed failed"
+ dodir /usr/share/man/man1/
+
+ ./install-cedilla || die "Install failed."
+
+ einstalldocs
+}