summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-11-22 23:39:33 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-11-22 23:39:33 +0900
commit3be53a2c635236ba4a5901954b6e5f6be90f5e55 (patch)
treec7aa0dc6f54665e49da52a4940488323af5896f2 /app-text/chasen
parentapp-text/chasen: update HOMEPAGE and SRC_URI (diff)
downloadgentoo-3be53a2c635236ba4a5901954b6e5f6be90f5e55.tar.gz
gentoo-3be53a2c635236ba4a5901954b6e5f6be90f5e55.tar.bz2
gentoo-3be53a2c635236ba4a5901954b6e5f6be90f5e55.zip
app-text/chasen: update to EAPI 8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-text/chasen')
-rw-r--r--app-text/chasen/chasen-2.4.4-r3.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/app-text/chasen/chasen-2.4.4-r3.ebuild b/app-text/chasen/chasen-2.4.4-r3.ebuild
index becbef0dcf99..2e8a2e5f4013 100644
--- a/app-text/chasen/chasen-2.4.4-r3.ebuild
+++ b/app-text/chasen/chasen-2.4.4-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="8"
-inherit epatch perl-module
+inherit perl-module
DESCRIPTION="Japanese Morphological Analysis System, ChaSen"
HOMEPAGE="https://chasen-legacy.osdn.jp/"
@@ -14,26 +14,25 @@ SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 ~riscv x86 ~sparc-solaris"
IUSE="perl static-libs"
+RDEPEND="virtual/libiconv"
DEPEND=">=dev-libs/darts-0.32"
-RDEPEND="${DEPEND}
- perl? ( !dev-perl/Text-ChaSen )"
PDEPEND=">=app-dicts/ipadic-2.7.0"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-cve-2011-4000.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-cve-2011-4000.patch )
src_configure() {
econf $(use_enable static-libs static)
- if use perl ; then
- cd "${S}"/perl
+
+ if use perl; then
+ cd "${S}"/perl || die
perl-module_src_configure
fi
}
src_compile() {
default
- if use perl ; then
+
+ if use perl; then
cd "${S}"/perl || die
perl-module_src_compile
fi
@@ -41,7 +40,8 @@ src_compile() {
src_test() {
default
- if use perl ; then
+
+ if use perl; then
cd "${S}"/perl || die
perl-module_src_test
fi
@@ -49,12 +49,11 @@ src_test() {
src_install() {
default
+ find "${ED}" -name '*.la' -delete || die
- if use perl ; then
+ if use perl; then
cd "${S}"/perl || die
perl-module_src_install
newdoc README README.perl
fi
-
- find "${ED}" -name '*.la' -delete || die
}